Skip to content

← Actionable
Medium, CVSS 6.8

Elasticsearch PKI Realm Authentication Bypass Vulnerability Allows User Impersonation Through Crafted Client Certificates

CVE-2025-37731GHSA-m9gh-789g-q5pv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.elasticsearch.plugin:x-pack-security 9.2.2, 9.1.8, 8.19.8; org.elasticsearch.plugin:x-pack-core 9.2.2, 9.1.8, 8.19.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-m9gh-789g-q5pv lists affected ranges: Maven org.elasticsearch.plugin:x-pack-security >=7.0.0-alpha1 =9.0.0-beta1 =9.2.0 =7.0.0-alpha1 =9.0.0-beta1 =9.2.0 <9.2.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-37731: 0.19% estimated exploitation activity in the next 30 days; percentile 8.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Authentication in Elasticsearch PKI realm can lead to user impersonation via specially crafted client certificates. A malicious actor would need to have such a crafted client certificate signed by a legitimate, trusted Certificate Authority.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m9gh-789g-q5pv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-37731

Advisory: Elasticsearch PKI Realm Authentication Bypass Vulnerability Allows User Impersonation Through Crafted Client Certificates
IDs: CVE-2025-37731, GHSA-m9gh-789g-q5pv
Record: https://patchnext.com/advisories/cve-2025-37731 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.elasticsearch.plugin:x-pack-security 9.2.2, 9.1.8, 8.19.8; org.elasticsearch.plugin:x-pack-core 9.2.2, 9.1.8, 8.19.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.elasticsearch.plugin:x-pack-security: affected >= 7.0.0-alpha1, < 8.19.8; >= 9.0.0-beta1, < 9.1.8; >= 9.2.0, < 9.2.2; fixed in 9.1.8, 8.19.8, 9.2.2
- Maven org.elasticsearch.plugin:x-pack-core: affected >= 7.0.0-alpha1, < 8.19.8; >= 9.0.0-beta1, < 9.1.8; >= 9.2.0, < 9.2.2; fixed in 9.1.8, 8.19.8, 9.2.2

## Suggested inspection (read-only)
- Maven org.elasticsearch.plugin:x-pack-security: check the installed version with your package manager.
- Maven org.elasticsearch.plugin:x-pack-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.elasticsearch.plugin:x-pack-security, org.elasticsearch.plugin:x-pack-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m9gh-789g-q5pv (GitHub-reviewed advisory GHSA-m9gh-789g-q5pv lists affected ranges: Maven org.elasticsearch.plugin:x-pack-security >=7.0.0-alpha1 =9.0.0-beta1 =9.2.0 =7.0.0-alpha1 =9.0.0-beta1 =9.2.0 <9.2.2)

Commands are suggestions: review each one before running it.

Loading voting…