OpenPubkey Vulnerable to Authentication Bypass
CVE-2025-3757GHSA-537f-gxgm-3jjq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openpubkey/openpubkey 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/openpubkey/openpubkey
- Affected
- < 0.10.0
- Fixed in
- 0.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-537f-gxgm-3jjq lists affected ranges: Go github.com/openpubkey/openpubkey >=0 <0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:L/SI:L/SA:L · score source
- EPSS
- CVE-2025-3757: 0.43% estimated exploitation activity in the next 30 days; percentile 37.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Versions of OpenPubkey library prior to 0.10.0 contained a vulnerability that would allow a specially crafted JWS to bypass signature verification. Patches Upgrade to v0.10.0 or greater. This vulnerability is not present in versions of OpenPubkey after v0.9.0. References CVE-2025-3757
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-537f-gxgm-3jjq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-3757 Advisory: OpenPubkey Vulnerable to Authentication Bypass IDs: CVE-2025-3757, GHSA-537f-gxgm-3jjq Record: https://patchnext.com/advisories/cve-2025-3757 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/openpubkey/openpubkey 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/openpubkey/openpubkey: affected < 0.10.0; fixed in 0.10.0 ## Suggested inspection (read-only) - Go github.com/openpubkey/openpubkey: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/openpubkey/openpubkey. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-537f-gxgm-3jjq (GitHub-reviewed advisory GHSA-537f-gxgm-3jjq lists affected ranges: Go github.com/openpubkey/openpubkey >=0 <0.10.0) Commands are suggestions: review each one before running it.
Loading voting…