Skip to content

← Actionable
Low, CVSS 1.3

Moodle has a CSRF risk in Brickfield tool's analysis request action

CVE-2025-3638GHSA-m8qh-hx4c-h9hr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.5.4, 4.4.8, 4.3.12, 4.1.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    < 4.1.18>= 4.3.0-beta, < 4.3.12>= 4.4.0-beta, < 4.4.8>= 4.5.0-beta, < 4.5.4
    Fixed in
    4.4.8, 4.1.18, 4.5.4, 4.3.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-3638: 0.30% estimated exploitation activity in the next 30 days; percentile 22.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m8qh-hx4c-h9hr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3638

Advisory: Moodle has a CSRF risk in Brickfield tool's analysis request action
IDs: CVE-2025-3638, GHSA-m8qh-hx4c-h9hr
Record: https://patchnext.com/advisories/cve-2025-3638 (revision 1, source checked 26 Oct 2026, 14:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.5.4, 4.4.8, 4.3.12, 4.1.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected < 4.1.18; >= 4.3.0-beta, < 4.3.12; >= 4.4.0-beta, < 4.4.8; >= 4.5.0-beta, < 4.5.4; fixed in 4.4.8, 4.1.18, 4.5.4, 4.3.12

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m8qh-hx4c-h9hr (GitHub-reviewed advisory GHSA-m8qh-hx4c-h9hr lists affected ranges: Packagist moodle/moodle >=0 =4.3.0-beta =4.4.0-beta =4.5.0-beta <4.5.4)

Commands are suggestions: review each one before running it.

Loading voting…