Skip to content

← Actionable
Medium, CVSS 6.9

Hibernate Validator may interpolate user-supplied input in a constraint violation message with Expression Language

CVE-2025-35036GHSA-7v6m-28jr-rg84

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.hibernate.validator:hibernate-validator 7.0.0.CR1, 6.2.0.CR1; org.hibernate:hibernate-validator 7.0.0.CR1, 6.2.0.CR1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-7v6m-28jr-rg84 lists affected ranges: Maven org.hibernate.validator:hibernate-validator >=0 =7.0.0.Alpha1 =0 =7.0.0.Alpha1 <7.0.0.CR1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-35036: 0.78% estimated exploitation activity in the next 30 days; percentile 56.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Hibernate Validator before 6.2.0 and 7.0.0, by default and depending how it is used, may interpolate user-supplied input in a constraint violation message with Expression Language. This could allow an attacker to access sensitive information or execute arbitrary Java code. Hibernate Validator as of 6.2.0 and 7.0.0 no longer interpolates custom constraint violation messages with Expression Language and strongly recommends not allowing user-supplied input in constraint violation messages. CVE-2020-5245 and CVE-2025-4428 are examples of related, downstream vulnerabilities involving Expression Language intepolation of user-supplied data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7v6m-28jr-rg84

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-35036

Advisory: Hibernate Validator may interpolate user-supplied input in a constraint violation message with Expression Language
IDs: CVE-2025-35036, GHSA-7v6m-28jr-rg84
Record: https://patchnext.com/advisories/cve-2025-35036 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.hibernate.validator:hibernate-validator 7.0.0.CR1, 6.2.0.CR1; org.hibernate:hibernate-validator 7.0.0.CR1, 6.2.0.CR1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.hibernate.validator:hibernate-validator: affected < 6.2.0.CR1; >= 7.0.0.Alpha1, < 7.0.0.CR1; fixed in 7.0.0.CR1, 6.2.0.CR1
- Maven org.hibernate:hibernate-validator: affected < 6.2.0.CR1; >= 7.0.0.Alpha1, < 7.0.0.CR1; fixed in 7.0.0.CR1, 6.2.0.CR1

## Suggested inspection (read-only)
- Maven org.hibernate.validator:hibernate-validator: check the installed version with your package manager.
- Maven org.hibernate:hibernate-validator: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.hibernate.validator:hibernate-validator, org.hibernate:hibernate-validator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7v6m-28jr-rg84 (GitHub-reviewed advisory GHSA-7v6m-28jr-rg84 lists affected ranges: Maven org.hibernate.validator:hibernate-validator >=0 =7.0.0.Alpha1 =0 =7.0.0.Alpha1 <7.0.0.CR1)

Commands are suggestions: review each one before running it.

Loading voting…