Cowrie has a SSRF vulnerability in wget/curl emulation enabling DDoS amplification
CVE-2025-34469GHSA-83jg-m2pm-4jxj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cowrie 2.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cowrie
- Affected
- < 2.9.0
- Fixed in
- 2.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-83jg-m2pm-4jxj lists affected ranges: PyPI cowrie >=0 <2.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-83jg-m2pm-4jxj lists affected ranges: PyPI cowrie >=0 <2.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L · score source
- EPSS
- CVE-2025-34469: 0.68% estimated exploitation activity in the next 30 days; percentile 52.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Server-Side Request Forgery (SSRF) vulnerability in Cowrie's emulated shell mode allows unauthenticated attackers to abuse the honeypot as an amplification vector for HTTP-based denial-of-service attacks against arbitrary third-party hosts. Details When Cowrie operates in emulated shell mode (the default configuration), it basically emulates common Linux commands. The wget and curl command emulations actually perform real outbound HTTP requests to the destinations specified by the attacker, as this functionality is intended to allow Cowrie to save downloaded files for later inspection. An attacker who connects to the honeypot via SSH or Telnet can repeatedly invoke these commands targeting a victim host. Since there was no rate limiting mechanism in place, the attacker could generate unlimited outbound HTTP traffic toward the victim. The requests originate from the honeypot's IP address, effectively masking the attacker's identity and turning the honeypot into an unwitting…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-83jg-m2pm-4jxj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-83jg-m2pm-4jxj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-34469 Advisory: Cowrie has a SSRF vulnerability in wget/curl emulation enabling DDoS amplification IDs: CVE-2025-34469, GHSA-83jg-m2pm-4jxj Record: https://patchnext.com/advisories/cve-2025-34469 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cowrie 2.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cowrie: affected < 2.9.0; fixed in 2.9.0 ## Suggested inspection (read-only) - `python -m pip show cowrie`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cowrie. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-83jg-m2pm-4jxj (OSV record GHSA-83jg-m2pm-4jxj lists affected ranges: PyPI cowrie >=0 <2.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-83jg-m2pm-4jxj (GitHub-reviewed advisory GHSA-83jg-m2pm-4jxj lists affected ranges: PyPI cowrie >=0 <2.9.0) Commands are suggestions: review each one before running it.
Loading voting…