Langflow CORS misconfiguration enables Account Takeover and RCE
CVE-2025-34291GHSA-577h-p2hh-v4mv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- <= 1.6.9
- Fixed in
- 1.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-577h-p2hh-v4mv lists affected ranges: PyPI langflow >=0 <=1.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2025-34291 to the Known Exploited Vulnerabilities catalog on 2026-05-21.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-05-21).
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-577h-p2hh-v4mv lists affected ranges: PyPI langflow >=0 <1.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-34291: 92.81% estimated exploitation activity in the next 30 days; percentile 99.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Langflow versions up to and including 1.6.9 contain a chained vulnerability that enables account takeover and remote code execution. An overly permissive CORS configuration (alloworigins='' with allowcredentials=True) combined with a refresh token cookie configured as SameSite=None allows a malicious webpage to perform cross-origin requests that include credentials and successfully call the refresh endpoint. An attacker-controlled origin can therefore obtain fresh accesstoken / refreshtoken pairs for a victim session. Obtained tokens permit access to authenticated endpoints — including built-in code-execution functionality — allowing the attacker to execute arbitrary code and achieve full system compromise.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-577h-p2hh-v4mv
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-577h-p2hh-v4mv
- Revision 1 · created ·
Published from ghsa record GHSA-577h-p2hh-v4mv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-34291 Advisory: Langflow CORS misconfiguration enables Account Takeover and RCE IDs: CVE-2025-34291, GHSA-577h-p2hh-v4mv Record: https://patchnext.com/advisories/cve-2025-34291 (revision 4, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: langflow 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected <= 1.6.9; fixed in 1.7.0 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-577h-p2hh-v4mv (GitHub-reviewed advisory GHSA-577h-p2hh-v4mv lists affected ranges: PyPI langflow >=0 <=1.6.9) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-34291 to the Known Exploited Vulnerabilities catalog on 2026-05-21.) - Verified: https://osv.dev/vulnerability/GHSA-577h-p2hh-v4mv (OSV record GHSA-577h-p2hh-v4mv lists affected ranges: PyPI langflow >=0 <1.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…