Skip to content

← Actionable
Medium, CVSS 4.0amended

http-proxy-middleware allows fixRequestBody to proceed even if bodyParser has failed

CVE-2025-32997GHSA-9gqv-wp59-fq42

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (http-proxy-middleware 3.0.5, 2.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2025-32997: 0.47% estimated exploitation activity in the next 30 days; percentile 40.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In http-proxy-middleware before 2.0.9 and 3.x before 3.0.5, fixRequestBody proceeds even if bodyParser has failed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9gqv-wp59-fq42

  2. Revision 1 · created ·

    Published from osv record GHSA-9gqv-wp59-fq42

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32997

Advisory: http-proxy-middleware allows fixRequestBody to proceed even if bodyParser has failed
IDs: CVE-2025-32997, GHSA-9gqv-wp59-fq42
Record: https://patchnext.com/advisories/cve-2025-32997 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: http-proxy-middleware 3.0.5, 2.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm http-proxy-middleware: affected >= 3.0.0, < 3.0.5; >= 1.3.0, < 2.0.9; fixed in 2.0.9, 3.0.5

## Suggested inspection (read-only)
- `npm ls http-proxy-middleware --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on http-proxy-middleware.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9gqv-wp59-fq42 (OSV record GHSA-9gqv-wp59-fq42 lists affected ranges: npm http-proxy-middleware >=1.3.0 =3.0.0 <3.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-9gqv-wp59-fq42 (GitHub-reviewed advisory GHSA-9gqv-wp59-fq42 lists affected ranges: npm http-proxy-middleware >=3.0.0 =1.3.0 <2.0.9)

Commands are suggestions: review each one before running it.

Loading voting…