org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type
CVE-2025-32974GHSA-mvgm-3rw2-7j4r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-security-requiredrights-default 16.2.0, 15.10.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default
- Affected
- >= 15.9-rc-1, < 15.10.8>= 16.0.0-rc-1, < 16.2.0
- Fixed in
- 15.10.8, 16.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mvgm-3rw2-7j4r lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default >=15.9-rc-1 =16.0.0-rc-1 <16.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-32974: 0.36% estimated exploitation activity in the next 30 days; percentile 29.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. To reproduce, as a user without script right, create a class with a TextArea property, create page with an object of that class and a Velocity macro in its content. Then, as an admin, try editing that page. Normally, there should be a warning but in vulnerable versions of XWiki, there is no warning. Patches This vulnerability has been patched in XWiki 15.10.8 and 16.2.0. Workarounds We're not aware of any workarounds apart from not editing pages that might have been edited by untrusted users as a user with…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mvgm-3rw2-7j4r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32974 Advisory: org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type IDs: CVE-2025-32974, GHSA-mvgm-3rw2-7j4r Record: https://patchnext.com/advisories/cve-2025-32974 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-security-requiredrights-default 16.2.0, 15.10.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default: affected >= 15.9-rc-1, < 15.10.8; >= 16.0.0-rc-1, < 16.2.0; fixed in 15.10.8, 16.2.0 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-security-requiredrights-default. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mvgm-3rw2-7j4r (GitHub-reviewed advisory GHSA-mvgm-3rw2-7j4r lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default >=15.9-rc-1 =16.0.0-rc-1 <16.2.0) Commands are suggestions: review each one before running it.
Loading voting…