The lesscss script service allows cache clearing without programming right
CVE-2025-32972GHSA-rp38-24m3-rx87
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-lesscss-script 16.8.0-rc-1, 16.4.3, 15.10.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-lesscss-script
- Affected
- >= 6.1-milestone-1, < 15.10.12>= 16.0.0-rc-1, < 16.4.3>= 16.5.0-rc-1, < 16.8.0-rc-1
- Fixed in
- 16.4.3, 16.8.0-rc-1, 15.10.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rp38-24m3-rx87 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-lesscss-script >=6.1-milestone-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.8.0-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2025-32972: 0.52% estimated exploitation activity in the next 30 days; percentile 44.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. Patches This has been patched in XWiki 15.10.12, 16.4.3 and 16.8.0 RC1. Workarounds We're not aware of any workaround except for being careful whom to give script right, which is a general recommendation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rp38-24m3-rx87
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32972 Advisory: The lesscss script service allows cache clearing without programming right IDs: CVE-2025-32972, GHSA-rp38-24m3-rx87 Record: https://patchnext.com/advisories/cve-2025-32972 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-lesscss-script 16.8.0-rc-1, 16.4.3, 15.10.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-lesscss-script: affected >= 6.1-milestone-1, < 15.10.12; >= 16.0.0-rc-1, < 16.4.3; >= 16.5.0-rc-1, < 16.8.0-rc-1; fixed in 16.4.3, 16.8.0-rc-1, 15.10.12 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-lesscss-script: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-lesscss-script. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rp38-24m3-rx87 (GitHub-reviewed advisory GHSA-rp38-24m3-rx87 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-lesscss-script >=6.1-milestone-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.8.0-rc-1) Commands are suggestions: review each one before running it.
Loading voting…