org.xwiki.platform:xwiki-platform-wysiwyg-api Open Redirect vulnerability
CVE-2025-32970GHSA-pjhg-9wr9-rj96
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-wysiwyg-api 16.8.0, 16.4.4, 15.10.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-wysiwyg-api
- Affected
- >= 13.5-rc-1, < 15.10.13>= 16.0.0-rc-1, < 16.4.4>= 16.5.0-rc-1, < 16.8.0
- Fixed in
- 15.10.13, 16.8.0, 16.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjhg-9wr9-rj96 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-wysiwyg-api >=13.5-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-32970: 0.60% estimated exploitation activity in the next 30 days; percentile 48.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An open redirect vulnerability in the HTML conversion request filter allows attackers to construct URLs on an XWiki instance that redirect to any URL. To reproduce, open <xwiki-host/xwiki/bin/view/Main/?foo=bar&foosyntax=invalid&RequiresHTMLConversion=foo&xerror=https://www.example.com/ where <xwiki-host is the URL of your XWiki installation. Patches This bug has been fixed in XWiki 15.10.13, 16.4.4 and 16.8.0 by validating the domain of the redirect URL against the configured safe domains and the current request's domain. Workarounds A web application firewall could be configured to reject requests with the xerror parameter as from our analysis this parameter isn't used anymore. For requests with the RequiresHTMLConversion parameter set, the referrer URL should be checked if it points to the XWiki installation. Apart from that, we're not aware of any workarounds.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pjhg-9wr9-rj96
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32970 Advisory: org.xwiki.platform:xwiki-platform-wysiwyg-api Open Redirect vulnerability IDs: CVE-2025-32970, GHSA-pjhg-9wr9-rj96 Record: https://patchnext.com/advisories/cve-2025-32970 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-wysiwyg-api 16.8.0, 16.4.4, 15.10.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-wysiwyg-api: affected >= 13.5-rc-1, < 15.10.13; >= 16.0.0-rc-1, < 16.4.4; >= 16.5.0-rc-1, < 16.8.0; fixed in 15.10.13, 16.8.0, 16.4.4 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-wysiwyg-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-wysiwyg-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pjhg-9wr9-rj96 (GitHub-reviewed advisory GHSA-pjhg-9wr9-rj96 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-wysiwyg-api >=13.5-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.8.0) Commands are suggestions: review each one before running it.
Loading voting…