Skip to content

← Actionable
High, CVSS 8.6

org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API

CVE-2025-32968GHSA-g9jj-75mx-wjcx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 16.10.1, 16.4.6, 15.10.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-g9jj-75mx-wjcx lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.6-milestone-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.10.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-32968: 0.59% estimated exploitation activity in the next 30 days; percentile 48.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. The vulnerability may be tested in a default installation of XWIki Standard Flavor, including using the official Docker containers. For example, with a MySQL or MariaDB database, you can use the following script (which a user having SCRIPT right but not PROGRAMMING right) to get the content of the xwikistrings table (which contain all the short string fields stored in objects, including passwords): Patches This has been patched in 16.10.1, 16.4.6 and 15.10.16. Workarounds There is no known workaround, other than upgrading XWiki. The protection added to this REST API is the same as the one used to validate…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g9jj-75mx-wjcx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32968

Advisory: org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API
IDs: CVE-2025-32968, GHSA-g9jj-75mx-wjcx
Record: https://patchnext.com/advisories/cve-2025-32968 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 16.10.1, 16.4.6, 15.10.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 1.6-milestone-1, < 15.10.16; >= 16.0.0-rc-1, < 16.4.6; >= 16.5.0-rc-1, < 16.10.1; fixed in 16.10.1, 16.4.6, 15.10.16

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g9jj-75mx-wjcx (GitHub-reviewed advisory GHSA-g9jj-75mx-wjcx lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.6-milestone-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.10.1)

Commands are suggestions: review each one before running it.

Loading voting…