Skip to content

← Actionable
High, CVSS 8.7amended

ses's global contour bindings leak into Compartment lexical scope

CVE-2025-32792GHSA-h9w6-f932-gq62

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ses 1.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ses

    Affected
    < 1.12.0
    Fixed in
    1.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-32792: 0.59% estimated exploitation activity in the next 30 days; percentile 48.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Web pages and web extensions using ses and the Compartment API to evaluate third-party code in an isolated execution environment that have also elsewhere used const, let, and class bindings in the top-level scope of a <script tag will have inadvertently revealed these bindings in the lexical scope of third-party code. Patches This compromise is addressed in ses version 1.12.0. The mechanism for confining third-party code involves a with block and a semi-opaque scope Proxy. The proxy previously revealed any named property to the surrounding lexical scope if it were absent on globalThis, so that the third-party code would receive an informative ReferenceError, relying on the invalid assumption that only properties of globalThis are in the top-level lexical scope. The solution makes the scope proxy fully opaque. Consequently, accessing an unbound free lexical name will produce undefined instead of throwing ReferenceError. Assigning to an unbound free lexical name will continue to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h9w6-f932-gq62

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h9w6-f932-gq62

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32792

Advisory: ses's global contour bindings leak into Compartment lexical scope
IDs: CVE-2025-32792, GHSA-h9w6-f932-gq62
Record: https://patchnext.com/advisories/cve-2025-32792 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ses 1.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ses: affected < 1.12.0; fixed in 1.12.0

## Suggested inspection (read-only)
- `npm ls ses --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ses.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h9w6-f932-gq62 (OSV record GHSA-h9w6-f932-gq62 lists affected ranges: npm ses >=0 <1.12.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h9w6-f932-gq62 (GitHub-reviewed advisory GHSA-h9w6-f932-gq62 lists affected ranges: npm ses >=0 <1.12.0)

Commands are suggestions: review each one before running it.

Loading voting…