OctoPrint Authenticated Reverse Proxy Page Authentication Bypass
CVE-2025-32788GHSA-qw93-h6pf-226x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- <= 1.10.3
- Fixed in
- 1.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qw93-h6pf-226x lists affected ranges: PyPI octoprint >=0 <1.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qw93-h6pf-226x lists affected ranges: PyPI octoprint >=0 <=1.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-32788: 0.25% estimated exploitation activity in the next 30 days; percentile 15.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OctoPrint versions up until and including 1.10.3 contain a vulnerability that allows an attacker to bypass the login redirect and directly access the rendered HTML of certain frontend pages. The impact on data exposure is minimal because, typically, data is loaded via API requests that correctly enforce user authentication. In the current codebase, cases where data is directly embedded in the page content are rare. However, one notable exception is the authenticated variant of the reverse proxy test page, which displays the IP addresses of configured reverse proxies. The primary risk lies in potential future modifications to the codebase that might incorrectly rely on the vulnerable internal functions for authentication checks, leading to security vulnerabilities. Patches The vulnerability has been patched in version 1.11.0. Details An authentication bypass vulnerability exists in the following functions defined in octoprint/server/util/init.py: - requirelogin -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qw93-h6pf-226x
- Revision 1 · created ·
Published from osv record GHSA-qw93-h6pf-226x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32788 Advisory: OctoPrint Authenticated Reverse Proxy Page Authentication Bypass IDs: CVE-2025-32788, GHSA-qw93-h6pf-226x Record: https://patchnext.com/advisories/cve-2025-32788 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 1.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected <= 1.10.3; fixed in 1.11.0 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qw93-h6pf-226x (OSV record GHSA-qw93-h6pf-226x lists affected ranges: PyPI octoprint >=0 <1.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qw93-h6pf-226x (GitHub-reviewed advisory GHSA-qw93-h6pf-226x lists affected ranges: PyPI octoprint >=0 <=1.10.3) Commands are suggestions: review each one before running it.
Loading voting…