Transformers vulnerable to ReDoS attack through its SETTING_RE variable
CVE-2025-3262GHSA-489j-g2vx-39wf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (transformers 4.51.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI transformers
- Affected
- >= 4.49.0, < 4.51.0
- Fixed in
- 4.51.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-489j-g2vx-39wf lists affected ranges: PyPI transformers >=4.49.0 <4.51.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-489j-g2vx-39wf lists affected ranges: PyPI transformers >=4.49.0 <4.51.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2025-3262: 0.49% estimated exploitation activity in the next 30 days; percentile 42.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Regular Expression Denial of Service (ReDoS) vulnerability was discovered in the huggingface/transformers repository, specifically in version 4.49.0. The vulnerability is due to inefficient regular expression complexity in the SETTINGRE variable within the transformers/commands/chat.py file. The regex contains repetition groups and non-optimized quantifiers, leading to exponential backtracking when processing 'almost matching' payloads. This can degrade application performance and potentially result in a denial-of-service (DoS) when handling specially crafted input strings. The issue is fixed in version 4.51.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-489j-g2vx-39wf
- Revision 1 · created ·
Published from osv record GHSA-489j-g2vx-39wf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-3262 Advisory: Transformers vulnerable to ReDoS attack through its SETTING_RE variable IDs: CVE-2025-3262, GHSA-489j-g2vx-39wf Record: https://patchnext.com/advisories/cve-2025-3262 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: transformers 4.51.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI transformers: affected >= 4.49.0, < 4.51.0; fixed in 4.51.0 ## Suggested inspection (read-only) - `python -m pip show transformers`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on transformers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-489j-g2vx-39wf (OSV record GHSA-489j-g2vx-39wf lists affected ranges: PyPI transformers >=4.49.0 <4.51.0 (fixed)) - Verified: https://github.com/advisories/GHSA-489j-g2vx-39wf (GitHub-reviewed advisory GHSA-489j-g2vx-39wf lists affected ranges: PyPI transformers >=4.49.0 <4.51.0) Commands are suggestions: review each one before running it.
Loading voting…