Skip to content

← Actionable
Medium, CVSS 6.2

ThingsBoard allows an authenticated user to upload malicious SVG images

CVE-2025-3261GHSA-5p82-2q3r-wj3m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.thingsboard:application 4.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

ThingsBoard in versions prior to v4.2.1 allows an authenticated user to upload malicious SVG images via the "Image Gallery", leading to a Stored Cross-Site Scripting (XSS) vulnerability. The exploit can be triggered when any user accesses the public API endpoint of the malicious SVG images, or if the malicious images are embedded in an iframe element, during a widget creation, deployed to any page of the platform (e.g., dashboards), and accessed during normal operations. The vulnerability resides in the ImageController, which fails to restrict the execution of JavaScript code when an image is loaded by the user's browser. This vulnerability can lead to the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and allowing unauthorized actions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5p82-2q3r-wj3m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3261

Advisory: ThingsBoard allows an authenticated user to upload malicious SVG images
IDs: CVE-2025-3261, GHSA-5p82-2q3r-wj3m
Record: https://patchnext.com/advisories/cve-2025-3261 (revision 1, source checked 26 Oct 2026, 16:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.thingsboard:application 4.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.thingsboard:application: affected < 4.2.1; fixed in 4.2.1

## Suggested inspection (read-only)
- Maven org.thingsboard:application: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.thingsboard:application.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5p82-2q3r-wj3m (GitHub-reviewed advisory GHSA-5p82-2q3r-wj3m lists affected ranges: Maven org.thingsboard:application >=0 <4.2.1)

Commands are suggestions: review each one before running it.

Loading voting…