vLLM Vulnerable to Remote Code Execution via Mooncake Integration
CVE-2025-32444GHSA-hj4w-hm2g-p6w5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.6.5, < 0.8.5
- Fixed in
- 0.8.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hj4w-hm2g-p6w5 lists affected ranges: PyPI vllm >=0.6.5 <0.8.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hj4w-hm2g-p6w5 lists affected ranges: PyPI vllm >=0.6.5 <0.8.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-32444: 1.82% estimated exploitation activity in the next 30 days; percentile 78.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impacted Deployments Note that vLLM instances that do NOT make use of the mooncake integration are NOT vulnerable. Description vLLM integration with mooncake is vaulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. This is a similar to GHSA - x3m8 - f7g5 - qhm7, the problem is in https://github.com/vllm-project/vllm/blob/32b14baf8a1f7195ca09484de3008063569b43c5/vllm/distributed/kvtransfer/kvpipe/mooncakepipe.py#L179 Here recvpyobj() Contains implicit pickle.loads(), which leads to potential RCE.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hj4w-hm2g-p6w5
- Revision 1 · created ·
Published from osv record GHSA-hj4w-hm2g-p6w5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32444 Advisory: vLLM Vulnerable to Remote Code Execution via Mooncake Integration IDs: CVE-2025-32444, GHSA-hj4w-hm2g-p6w5 Record: https://patchnext.com/advisories/cve-2025-32444 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.6.5, < 0.8.5; fixed in 0.8.5 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hj4w-hm2g-p6w5 (OSV record GHSA-hj4w-hm2g-p6w5 lists affected ranges: PyPI vllm >=0.6.5 <0.8.5 (fixed)) - Verified: https://github.com/advisories/GHSA-hj4w-hm2g-p6w5 (GitHub-reviewed advisory GHSA-hj4w-hm2g-p6w5 lists affected ranges: PyPI vllm >=0.6.5 <0.8.5) Commands are suggestions: review each one before running it.
Loading voting…