Skip to content

← Actionable
Critical, CVSS 10.0Exploited · CISA KEV

Craft CMS Allows Remote Code Execution

CVE-2025-32432GHSA-f3gw-9ww9-jmc3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.6.17, 4.14.15, 3.9.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 3.0.0-RC1, <= 3.9.14>= 4.0.0-RC1, <= 4.14.14>= 5.0.0-RC1, <= 5.6.16
    Fixed in
    5.6.17, 3.9.15, 4.14.15

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2025-32432: 99.79% estimated exploitation activity in the next 30 days; percentile 99.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is an additional fix for https://github.com/craftcms/cms/security/advisories/GHSA-4w8r-3xrw-v25g This is a high-impact, low-complexity attack vector. To mitigate the issue, users running Craft installations before the fixed versions are encouraged to update to at least that version. Details https://craftcms.com/knowledge-base/craft-cms-cve-2025-32432 References https://github.com/craftcms/cms/commit/e1c85441fa47eeb7c688c2053f25419bc0547b47 https://github.com/craftcms/cms/blob/3.x/CHANGELOG.md#3915---2025-04-10-critical https://github.com/craftcms/cms/blob/4.x/CHANGELOG.md#41415---2025-04-10-critical https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5617---2025-04-10-critical https://sensepost.com/blog/2025/investigating-an-in-the-wild-campaign-using-rce-in-craftcms/ Credits Credit to Orange Cyberdefense for discovering a reporting this bug.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f3gw-9ww9-jmc3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32432

Advisory: Craft CMS Allows Remote Code Execution
IDs: CVE-2025-32432, GHSA-f3gw-9ww9-jmc3
Record: https://patchnext.com/advisories/cve-2025-32432 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.6.17, 4.14.15, 3.9.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 3.0.0-RC1, <= 3.9.14; >= 4.0.0-RC1, <= 4.14.14; >= 5.0.0-RC1, <= 5.6.16; fixed in 5.6.17, 3.9.15, 4.14.15

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-32432 to the Known Exploited Vulnerabilities catalog on 2026-03-20.)
- Verified: https://github.com/advisories/GHSA-f3gw-9ww9-jmc3 (GitHub-reviewed advisory GHSA-f3gw-9ww9-jmc3 lists affected ranges: Packagist craftcms/cms >=3.0.0-RC1 =4.0.0-RC1 =5.0.0-RC1 <=5.6.16)

Commands are suggestions: review each one before running it.

Loading voting…