Next.js Race Condition to Cache Poisoning
CVE-2025-32421GHSA-qpjv-v59x-3qc4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 15.1.6, 14.2.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 15.0.0, < 15.1.6>= 0.9.9, < 14.2.24
- Fixed in
- 14.2.24, 15.1.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qpjv-v59x-3qc4 lists affected ranges: npm next >=0.9.9 =15.0.0 <15.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qpjv-v59x-3qc4 lists affected ranges: npm next >=15.0.0 =0.9.9 <14.2.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-32421: 0.80% estimated exploitation activity in the next 30 days; percentile 56.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary We received a responsible disclosure from Allam Rachid (zhero) for a low-severity race-condition vulnerability in Next.js. This issue only affects the Pages Router under certain misconfigurations, causing normal endpoints to serve pageProps data instead of standard HTML. Learn more here Credit Thank you to Allam Rachid (zhero) for the responsible disclosure. This research was rewarded as part of our bug bounty program.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qpjv-v59x-3qc4
- Revision 1 · created ·
Published from osv record GHSA-qpjv-v59x-3qc4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32421 Advisory: Next.js Race Condition to Cache Poisoning IDs: CVE-2025-32421, GHSA-qpjv-v59x-3qc4 Record: https://patchnext.com/advisories/cve-2025-32421 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 15.1.6, 14.2.24. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 15.0.0, < 15.1.6; >= 0.9.9, < 14.2.24; fixed in 14.2.24, 15.1.6 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qpjv-v59x-3qc4 (OSV record GHSA-qpjv-v59x-3qc4 lists affected ranges: npm next >=0.9.9 =15.0.0 <15.1.6 (fixed)) - Verified: https://github.com/advisories/GHSA-qpjv-v59x-3qc4 (GitHub-reviewed advisory GHSA-qpjv-v59x-3qc4 lists affected ranges: npm next >=15.0.0 =0.9.9 <14.2.24) Commands are suggestions: review each one before running it.
Loading voting…