Skip to content

← Actionable
Medium, CVSS 6.0amended

Vite has an server.fs.deny bypass with an invalid request-target

CVE-2025-32395GHSA-356w-63v5-8wf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 6.2.6, 6.1.5, 6.0.15, 5.4.18, 4.5.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vite

    Affected
    >= 6.2.0, < 6.2.6>= 6.1.0, < 6.1.5>= 6.0.0, < 6.0.15>= 5.0.0, < 5.4.18< 4.5.13
    Fixed in
    6.0.15, 6.2.6, 4.5.13, 5.4.18, 6.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-32395: 1.81% estimated exploitation activity in the next 30 days; percentile 78.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The contents of arbitrary files can be returned to the browser if the dev server is running on Node or Bun. Impact Only apps with the following conditions are affected. - explicitly exposing the Vite dev server to the network (using --host or server.host config option) - running the Vite dev server on runtimes that are not Deno (e.g. Node, Bun) Details HTTP 1.1 spec (RFC 9112) does not allow

in request-target. Although an attacker can send such a request. For those requests with an invalid request-line (it includes request-target), the spec recommends to reject them with 400 or 301. The same can be said for HTTP 2 (ref1, ref2, ref3). On Node and Bun, those requests are not rejected internally and is passed to the user land. For those requests, the value of http.IncomingMessage.url contains #. Vite assumed req.url won't contain

when checking server.fs.deny, allowing those kinds of requests to bypass the check. On Deno, those requests are not rejected internally and is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-356w-63v5-8wf4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-356w-63v5-8wf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32395

Advisory: Vite has an `server.fs.deny` bypass with an invalid `request-target`
IDs: CVE-2025-32395, GHSA-356w-63v5-8wf4
Record: https://patchnext.com/advisories/cve-2025-32395 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vite 6.2.6, 6.1.5, 6.0.15, 5.4.18, 4.5.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vite: affected >= 6.2.0, < 6.2.6; >= 6.1.0, < 6.1.5; >= 6.0.0, < 6.0.15; >= 5.0.0, < 5.4.18; < 4.5.13; fixed in 6.0.15, 6.2.6, 4.5.13, 5.4.18, 6.1.5

## Suggested inspection (read-only)
- `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-356w-63v5-8wf4 (OSV record GHSA-356w-63v5-8wf4 lists affected ranges: npm vite >=6.2.0 =6.1.0 =6.0.0 =5.0.0 =0 <4.5.13 (fixed))
- Verified: https://github.com/advisories/GHSA-356w-63v5-8wf4 (GitHub-reviewed advisory GHSA-356w-63v5-8wf4 lists affected ranges: npm vite >=6.2.0 =6.1.0 =6.0.0 =5.0.0 =0 <4.5.13)

Commands are suggestions: review each one before running it.

Loading voting…