@sveltejs/kit vulnerable to Cross-site Scripting via tracked search_params
CVE-2025-32388GHSA-6q87-84jw-cjhp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 2.20.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sveltejs/kit
- Affected
- >= 2.0.0, < 2.20.6
- Fixed in
- 2.20.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6q87-84jw-cjhp lists affected ranges: npm @sveltejs/kit >=2.0.0 <2.20.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6q87-84jw-cjhp lists affected ranges: npm @sveltejs/kit >=2.0.0 <2.20.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-32388: 0.30% estimated exploitation activity in the next 30 days; percentile 23.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Unsanitized search param names cause XSS vulnerability. You are affected if you iterate over all entries of event.url.searchParams inside a server load function. Attackers can exploit it by crafting a malicious URL and getting a user to click a link with said URL. Details SvelteKit tracks which parameters in event.url.searchParams are read inside server load functions. If the application iterates over the these parameters, the uses.searchparams array included in the boot script (embedded in the server-rendered HTML) will have any search param name included in unsanitized form. packages/kit/src/runtime/server/utils.js:150 has the stringifyuses(node) function which prints these out. Reproduction In a +page.server.js or +layout.server.js: If a user visits the page in question via a link containing ?</script/<scriptwindow.pwned%3D1</script/, the </script will be included verbatim in the payload, causing the embedded script to be executed. It is not necessary to return the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6q87-84jw-cjhp
- Revision 1 · created ·
Published from osv record GHSA-6q87-84jw-cjhp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32388 Advisory: @sveltejs/kit vulnerable to Cross-site Scripting via tracked search_params IDs: CVE-2025-32388, GHSA-6q87-84jw-cjhp Record: https://patchnext.com/advisories/cve-2025-32388 (revision 2, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 2.20.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sveltejs/kit: affected >= 2.0.0, < 2.20.6; fixed in 2.20.6 ## Suggested inspection (read-only) - `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sveltejs/kit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6q87-84jw-cjhp (OSV record GHSA-6q87-84jw-cjhp lists affected ranges: npm @sveltejs/kit >=2.0.0 <2.20.6 (fixed)) - Verified: https://github.com/advisories/GHSA-6q87-84jw-cjhp (GitHub-reviewed advisory GHSA-6q87-84jw-cjhp lists affected ranges: npm @sveltejs/kit >=2.0.0 <2.20.6) Commands are suggestions: review each one before running it.
Loading voting…