xgrammar Vulnerable to Denial of Service (DoS) by abusing unbounded cache in memory
CVE-2025-32381GHSA-389x-67px-mjg3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (xgrammar 0.1.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI xgrammar
- Affected
- < 0.1.18
- Fixed in
- 0.1.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-389x-67px-mjg3 lists affected ranges: PyPI xgrammar >=0 <0.1.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-389x-67px-mjg3 lists affected ranges: PyPI xgrammar >=0 <0.1.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-32381: 0.52% estimated exploitation activity in the next 30 days; percentile 44.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Xgrammar includes a cache for compiled grammars to increase performance with repeated use of the same grammar. This cache is held in memory. Since the cache is unbounded, a system making use of xgrammar can be abused to fill up a host's memory and case a denial of service. For example, sending many small requests to an LLM inference server with unique JSON schemas would eventually cause this denial of service to occur. Details The fix is to add a limit to the cache size. This was done in https://github.com/mlc-ai/xgrammar/pull/243 An example of making use of the new cache size limit can be found in vLLM here: https://github.com/vllm-project/vllm/pull/16283 Impact Any system making use of Xgrammar and taking requests as input from potentially untrusted parties would be vulnerable to this denial of service issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-389x-67px-mjg3
- Revision 1 · created ·
Published from osv record GHSA-389x-67px-mjg3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32381 Advisory: xgrammar Vulnerable to Denial of Service (DoS) by abusing unbounded cache in memory IDs: CVE-2025-32381, GHSA-389x-67px-mjg3 Record: https://patchnext.com/advisories/cve-2025-32381 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: xgrammar 0.1.18. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI xgrammar: affected < 0.1.18; fixed in 0.1.18 ## Suggested inspection (read-only) - `python -m pip show xgrammar`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on xgrammar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-389x-67px-mjg3 (OSV record GHSA-389x-67px-mjg3 lists affected ranges: PyPI xgrammar >=0 <0.1.18 (fixed)) - Verified: https://github.com/advisories/GHSA-389x-67px-mjg3 (GitHub-reviewed advisory GHSA-389x-67px-mjg3 lists affected ranges: PyPI xgrammar >=0 <0.1.18) Commands are suggestions: review each one before running it.
Loading voting…