Skip to content

← Actionable
High, CVSS 7.5

Apollo Router Query Validation Vulnerable to Excessive Resource Consumption via Named Fragment Processing

CVE-2025-32380GHSA-3j43-9v8v-cp3f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apollo-router 2.1.1, 1.61.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io apollo-router

    Affected
    < 1.61.2>= 2.0.0-alpha.0, < 2.1.1
    Fixed in
    1.61.2, 2.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-32380: 0.58% estimated exploitation activity in the next 30 days; percentile 47.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Summary A vulnerability in Apollo Router's usage of Apollo Compiler allowed queries with deeply nested and reused named fragments to be prohibitively expensive to validate. This could lead to excessive resource consumption and denial of service. Details Named fragments were being processed once per fragment spread in some cases during query validation, leading to exponential resource usage when deeply nested and reused fragments were involved. Fix/Mitigation Apollo Router's usage of Apollo Compiler has been updated so that validation logic processes each named fragment only once, preventing redundant traversal. Patches This has been remediated in apollo-router versions 1.61.2 and 2.1.1. Workarounds The only known workaround is "Safelisting with IDs only" per Safelisting with Persisted Queries - Apollo GraphQL Docs. The "Safelisting" security level is not sufficient, since that level allows freeform GraphQL queries to be sent to Apollo Router. References Query Planning…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3j43-9v8v-cp3f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32380

Advisory: Apollo Router Query Validation Vulnerable to Excessive Resource Consumption via Named Fragment Processing
IDs: CVE-2025-32380, GHSA-3j43-9v8v-cp3f
Record: https://patchnext.com/advisories/cve-2025-32380 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apollo-router 2.1.1, 1.61.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io apollo-router: affected < 1.61.2; >= 2.0.0-alpha.0, < 2.1.1; fixed in 1.61.2, 2.1.1

## Suggested inspection (read-only)
- crates.io apollo-router: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apollo-router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3j43-9v8v-cp3f (GitHub-reviewed advisory GHSA-3j43-9v8v-cp3f lists affected ranges: crates.io apollo-router >=0 =2.0.0-alpha.0 <2.1.1)

Commands are suggestions: review each one before running it.

Loading voting…