Shopware default newsletter opt-in settings allow for mass sign-up abuse
CVE-2025-32378GHSA-4h9w-7vfp-px8m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17; shopware/platform 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- >= 6.6.0.0-rc1, < 6.6.10.3>= 6.7.0.0-rc1, < 6.7.0.0-rc2< 6.5.8.17
- Fixed in
- 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2
Packagist shopware/platform
- Affected
- >= 6.6.0.0-rc1, < 6.6.10.3>= 6.7.0.0-rc1, < 6.7.0.0-rc2< 6.5.8.17
- Fixed in
- 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4h9w-7vfp-px8m lists affected ranges: Packagist shopware/core >=6.6.0.0-rc1 =6.7.0.0-rc1 =0 =6.6.0.0-rc1 =6.7.0.0-rc1 =0 <6.5.8.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2025-32378: 0.32% estimated exploitation activity in the next 30 days; percentile 24.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Currently the default settings for double-opt-in allow for mass unsolicited newsletter sign-ups without confirmation. Default settings are: Newsletter: Double Opt-in - active Newsletter: Double opt-in for registered customers - disabled Log-in & sign-up: Double opt-in on sign-up - disabled With these settings, anyone can register an account on the shop using any e-mail-address and then check the check-box in the account page to sign up for the newsletter. The recipient will receive two mails confirming registering and signing up for the newsletter, no confirmation link needed to be clicked for either. In the backend the recipient is set to “instantly active”. Patches Update to Shopware 6.6.10.3 or 6.5.8.17 Workarounds For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4h9w-7vfp-px8m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32378 Advisory: Shopware default newsletter opt-in settings allow for mass sign-up abuse IDs: CVE-2025-32378, GHSA-4h9w-7vfp-px8m Record: https://patchnext.com/advisories/cve-2025-32378 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17; shopware/platform 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected >= 6.6.0.0-rc1, < 6.6.10.3; >= 6.7.0.0-rc1, < 6.7.0.0-rc2; < 6.5.8.17; fixed in 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2 - Packagist shopware/platform: affected >= 6.6.0.0-rc1, < 6.6.10.3; >= 6.7.0.0-rc1, < 6.7.0.0-rc2; < 6.5.8.17; fixed in 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4h9w-7vfp-px8m (GitHub-reviewed advisory GHSA-4h9w-7vfp-px8m lists affected ranges: Packagist shopware/core >=6.6.0.0-rc1 =6.7.0.0-rc1 =0 =6.6.0.0-rc1 =6.7.0.0-rc1 =0 <6.5.8.17) Commands are suggestions: review each one before running it.
Loading voting…