Mattermost allows an unauthorized Guest user access to Playbook
CVE-2025-3228GHSA-4578-6gjh-f2jm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.8.1, 10.7.3, 10.6.6, 10.5.6, 9.11.16, 8.0.0-20250520060012-d0380305ef7a; github.com/mattermost/mattermost-server 0.0.0-20250520060012-d0380305ef7a), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20250520060012-d0380305ef7a>= 10.5.0, <= 10.5.5>= 9.11.0, <= 9.11.15>= 10.8.0, <= 10.8.0>= 10.7.0, <= 10.7.2>= 10.6.0, <= 10.6.5
- Fixed in
- 9.11.16, 10.5.6, 10.8.1, 10.7.3, 10.6.6, 8.0.0-20250520060012-d0380305ef7a
Go github.com/mattermost/mattermost-server
- Affected
- < 0.0.0-20250520060012-d0380305ef7a
- Fixed in
- 0.0.0-20250520060012-d0380305ef7a
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4578-6gjh-f2jm lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =0 =10.5.0 =9.11.0 =10.8.0 =10.7.0 =10.6.0 <=10.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-3228: 0.29% estimated exploitation activity in the next 30 days; percentile 22.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.5.x <= 10.5.5, 9.11.x <= 9.11.15, 10.8.x <= 10.8.0, 10.7.x <= 10.7.2, 10.6.x <= 10.6.5 fail to properly retrieve requestorInfo from playbooks handler for guest users which allows an attacker access to the playbook run.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4578-6gjh-f2jm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-3228 Advisory: Mattermost allows an unauthorized Guest user access to Playbook IDs: CVE-2025-3228, GHSA-4578-6gjh-f2jm Record: https://patchnext.com/advisories/cve-2025-3228 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.8.1, 10.7.3, 10.6.6, 10.5.6, 9.11.16, 8.0.0-20250520060012-d0380305ef7a; github.com/mattermost/mattermost-server 0.0.0-20250520060012-d0380305ef7a. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250520060012-d0380305ef7a; >= 10.5.0, <= 10.5.5; >= 9.11.0, <= 9.11.15; >= 10.8.0, <= 10.8.0; >= 10.7.0, <= 10.7.2; >= 10.6.0, <= 10.6.5; fixed in 9.11.16, 10.5.6, 10.8.1, 10.7.3, 10.6.6, 8.0.0-20250520060012-d0380305ef7a - Go github.com/mattermost/mattermost-server: affected < 0.0.0-20250520060012-d0380305ef7a; fixed in 0.0.0-20250520060012-d0380305ef7a ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4578-6gjh-f2jm (GitHub-reviewed advisory GHSA-4578-6gjh-f2jm lists affected ranges: Go github.com/mattermost/mattermost-server >=0 =0 =10.5.0 =9.11.0 =10.8.0 =10.7.0 =10.6.0 <=10.6.5) Commands are suggestions: review each one before running it.
Loading voting…