LlamaIndex has an XML Entity Expansion vulnerability in its sitemap parser
CVE-2025-3225GHSA-w42r-mrx7-c633
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index-readers-papers 0.3.2; llama-index 0.12.29), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index-readers-papers
- Affected
- < 0.3.2
- Fixed in
- 0.3.2
PyPI llama-index
- Affected
- >= 0.12.21, < 0.12.29
- Fixed in
- 0.12.29
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w42r-mrx7-c633 lists affected ranges: PyPI llama-index-readers-papers >=0 <0.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2025-250 lists affected ranges: PyPI llama-index >=0.12.21 <0.12.29 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w42r-mrx7-c633 lists affected ranges: PyPI llama-index-readers-papers >=0 <0.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-3225: 0.48% estimated exploitation activity in the next 30 days; percentile 41.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An XML Entity Expansion vulnerability, also known as a 'billion laughs' attack, exists in the sitemap parser of the run-llama/llamaindex repository, specifically affecting the Papers Loaders package before version 0.3.2 (in llama-index v0.10.0 and above through v0.12.29). This vulnerability allows an attacker to supply a malicious Sitemap XML, leading to a Denial of Service (DoS) by exhausting system memory and potentially causing a system crash. The issue is resolved in version 0.3.2 (in llama-index 0.12.29).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w42r-mrx7-c633
- Revision 2 · amended ·
Amended from osv record PYSEC-2025-250
- Revision 1 · created ·
Published from osv record GHSA-w42r-mrx7-c633
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-3225 Advisory: LlamaIndex has an XML Entity Expansion vulnerability in its sitemap parser IDs: CVE-2025-3225, GHSA-w42r-mrx7-c633 Record: https://patchnext.com/advisories/cve-2025-3225 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-index-readers-papers 0.3.2; llama-index 0.12.29. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-index-readers-papers: affected < 0.3.2; fixed in 0.3.2 - PyPI llama-index: affected >= 0.12.21, < 0.12.29; fixed in 0.12.29 ## Suggested inspection (read-only) - `python -m pip show llama-index-readers-papers`: prints the installed version. Run with the environment that serves production active. - `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-index-readers-papers, llama-index. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w42r-mrx7-c633 (OSV record GHSA-w42r-mrx7-c633 lists affected ranges: PyPI llama-index-readers-papers >=0 <0.3.2 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2025-250 (OSV record PYSEC-2025-250 lists affected ranges: PyPI llama-index >=0.12.21 <0.12.29 (fixed)) - Verified: https://github.com/advisories/GHSA-w42r-mrx7-c633 (GitHub-reviewed advisory GHSA-w42r-mrx7-c633 lists affected ranges: PyPI llama-index-readers-papers >=0 <0.3.2) Commands are suggestions: review each one before running it.
Loading voting…