Skip to content

← Actionable
High, CVSS 7.5amended

Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion

CVE-2025-32030GHSA-q2f9-x4p4-7xmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apollo/gateway 2.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-32030: 0.53% estimated exploitation activity in the next 30 days; percentile 44.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Summary A vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. This could lead to excessive resource consumption and denial of service. Details Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. Fix/Mitigation A new Query Fragment Expansion Limit metric has been introduced: - This metric computes the number of selections a query would have if its fragment spreads were fully expanded. - The metric is checked against a limit to prevent excessive computation. Patches This has been remediated in @apollo/gateway version 2.10.1. Workarounds No known direct workarounds exist. References Query Planning Documentation Acknowledgements We appreciate the efforts of the security community in identifying and improving the performance and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q2f9-x4p4-7xmh

  2. Revision 1 · created ·

    Published from osv record GHSA-q2f9-x4p4-7xmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32030

Advisory: Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion
IDs: CVE-2025-32030, GHSA-q2f9-x4p4-7xmh
Record: https://patchnext.com/advisories/cve-2025-32030 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apollo/gateway 2.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apollo/gateway: affected < 2.10.1; fixed in 2.10.1

## Suggested inspection (read-only)
- `npm ls @apollo/gateway --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apollo/gateway.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q2f9-x4p4-7xmh (OSV record GHSA-q2f9-x4p4-7xmh lists affected ranges: npm @apollo/gateway >=0 <2.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-q2f9-x4p4-7xmh (GitHub-reviewed advisory GHSA-q2f9-x4p4-7xmh lists affected ranges: npm @apollo/gateway >=0 <2.10.1)

Commands are suggestions: review each one before running it.

Loading voting…