crud-query-parser SQL Injection vulnerability
CVE-2025-32020GHSA-9r25-rp3p-h2w4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (crud-query-parser 0.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.1.0
- Fixed in
- 0.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9r25-rp3p-h2w4 lists affected ranges: npm crud-query-parser >=0 <0.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9r25-rp3p-h2w4 lists affected ranges: npm crud-query-parser >=0 <0.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-32020: 0.37% estimated exploitation activity in the next 30 days; percentile 31.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Improper neutralization of the order/sort parameter in the TypeORM adapter, which allows SQL injection. You are impacted by this vulnerability if you are using the TypeORM adapter, ordering is enabled and you have not set-up a property filter. Versions 0.0.1, 0.0.2 and 0.0.3 are affected by this vulnerability. Patches This vulnerability has been fixed in version 0.1.0 and newer, which introduces TypeORM field validation (enabled by default). Workarounds Add an allowlist of fields List all valid fields and use the filterProperties function to filter out invalid fields before passing the crudRequest to the TypeOrmQueryAdapter. Here's an example: Disable ordering Cleanup the order field just before passing it to the TypeOrmQueryAdapter. Here's an example:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9r25-rp3p-h2w4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9r25-rp3p-h2w4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32020 Advisory: crud-query-parser SQL Injection vulnerability IDs: CVE-2025-32020, GHSA-9r25-rp3p-h2w4 Record: https://patchnext.com/advisories/cve-2025-32020 (revision 3, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: crud-query-parser 0.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm crud-query-parser: affected < 0.1.0; fixed in 0.1.0 ## Suggested inspection (read-only) - `npm ls crud-query-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on crud-query-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9r25-rp3p-h2w4 (OSV record GHSA-9r25-rp3p-h2w4 lists affected ranges: npm crud-query-parser >=0 <0.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9r25-rp3p-h2w4 (GitHub-reviewed advisory GHSA-9r25-rp3p-h2w4 lists affected ranges: npm crud-query-parser >=0 <0.1.0) Commands are suggestions: review each one before running it.
Loading voting…