Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users
CVE-2025-32017GHSA-q62r-8ppj-xvf4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (umbraco.cms 15.3.1, 14.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet umbraco.cms
- Affected
- >= 14.0.0--preview004, < 14.3.4>= 15.0.0-rc1, < 15.3.1
- Fixed in
- 15.3.1, 14.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q62r-8ppj-xvf4 lists affected ranges: NuGet umbraco.cms >=14.0.0--preview004 =15.0.0-rc1 <15.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-32017: 0.65% estimated exploitation activity in the next 30 days; percentile 51.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Authenticated users to the Umbraco backoffice are able to craft management API request that exploit a path traversal vulnerability to upload files into a incorrect location. Patches The issue affects Umbraco 14+ and is patched in 14.3.4 and 15.3.1. Workarounds Umbraco supports the configuration of allowed and disallowed file extensions. Using these options to allow only necessary file extensions significantly reduces the scope of the vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q62r-8ppj-xvf4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32017 Advisory: Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users IDs: CVE-2025-32017, GHSA-q62r-8ppj-xvf4 Record: https://patchnext.com/advisories/cve-2025-32017 (revision 1, source checked 26 Oct 2026, 17:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: umbraco.cms 15.3.1, 14.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet umbraco.cms: affected >= 14.0.0--preview004, < 14.3.4; >= 15.0.0-rc1, < 15.3.1; fixed in 15.3.1, 14.3.4 ## Suggested inspection (read-only) - NuGet umbraco.cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on umbraco.cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q62r-8ppj-xvf4 (GitHub-reviewed advisory GHSA-q62r-8ppj-xvf4 lists affected ranges: NuGet umbraco.cms >=14.0.0--preview004 =15.0.0-rc1 <15.3.1) Commands are suggestions: review each one before running it.
Loading voting…