Drupal Core Cross-Site Scripting (XSS) Vulnerability
CVE-2025-31675GHSA-m4wj-hhwj-47qp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.1.5, 11.0.13, 10.4.5, 10.3.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 8.0.0, < 10.3.14>= 10.4.0, < 10.4.5>= 11.0.0, < 11.0.13>= 11.1.0, < 11.1.5
- Fixed in
- 11.0.13, 11.1.5, 10.3.14, 10.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m4wj-hhwj-47qp lists affected ranges: Packagist drupal/core >=8.0.0 =10.4.0 =11.0.0 =11.1.0 <11.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2025-31675: 0.50% estimated exploitation activity in the next 30 days; percentile 43.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m4wj-hhwj-47qp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-31675 Advisory: Drupal Core Cross-Site Scripting (XSS) Vulnerability IDs: CVE-2025-31675, GHSA-m4wj-hhwj-47qp Record: https://patchnext.com/advisories/cve-2025-31675 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.1.5, 11.0.13, 10.4.5, 10.3.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 8.0.0, < 10.3.14; >= 10.4.0, < 10.4.5; >= 11.0.0, < 11.0.13; >= 11.1.0, < 11.1.5; fixed in 11.0.13, 11.1.5, 10.3.14, 10.4.5 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m4wj-hhwj-47qp (GitHub-reviewed advisory GHSA-m4wj-hhwj-47qp lists affected ranges: Packagist drupal/core >=8.0.0 =10.4.0 =11.0.0 =11.1.0 <11.1.5) Commands are suggestions: review each one before running it.
Loading voting…