Skip to content

← Actionable
Medium, CVSS 6.9

Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing

CVE-2025-31672GHSA-gmg8-593g-7mv3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.poi:poi-ooxml 5.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-31672: 1.38% estimated exploitation activity in the next 30 days; percentile 72.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gmg8-593g-7mv3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31672

Advisory: Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing
IDs: CVE-2025-31672, GHSA-gmg8-593g-7mv3
Record: https://patchnext.com/advisories/cve-2025-31672 (revision 1, source checked 26 Oct 2026, 16:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.poi:poi-ooxml 5.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.poi:poi-ooxml: affected < 5.4.0; fixed in 5.4.0

## Suggested inspection (read-only)
- Maven org.apache.poi:poi-ooxml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.poi:poi-ooxml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gmg8-593g-7mv3 (GitHub-reviewed advisory GHSA-gmg8-593g-7mv3 lists affected ranges: Maven org.apache.poi:poi-ooxml >=0 <5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…