Apache Tomcat Denial of Service via invalid HTTP priority header
CVE-2025-31650GHSA-3p2h-wqq4-wf4h
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 9.0.76, <= 9.0.102>= 10.1.10, < 10.1.40>= 11.0.0-M2, < 11.0.6>= 8.5.0, <= 8.5.100
- Fixed in
- 9.0.104, 10.1.40, 11.0.6
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 9.0.76, <= 9.0.102>= 10.1.10, < 10.1.40>= 11.0.0-M2, < 11.0.6>= 8.5.0, <= 8.5.100
- Fixed in
- 9.0.104, 10.1.40, 11.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3p2h-wqq4-wf4h lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=9.0.76 =10.1.10 =11.0.0-M2 =8.5.0 =9.0.76 =10.1.10 =11.0.0-M2 =8.5.0 <=8.5.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-31650: 61.32% estimated exploitation activity in the next 30 days; percentile 99.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3p2h-wqq4-wf4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-31650 Advisory: Apache Tomcat Denial of Service via invalid HTTP priority header IDs: CVE-2025-31650, GHSA-3p2h-wqq4-wf4h Record: https://patchnext.com/advisories/cve-2025-31650 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.6, 10.1.40, 9.0.104; org.apache.tomcat.embed:tomcat-embed-core 11.0.6, 10.1.40, 9.0.104. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 9.0.76, <= 9.0.102; >= 10.1.10, < 10.1.40; >= 11.0.0-M2, < 11.0.6; >= 8.5.0, <= 8.5.100; fixed in 9.0.104, 10.1.40, 11.0.6 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.76, <= 9.0.102; >= 10.1.10, < 10.1.40; >= 11.0.0-M2, < 11.0.6; >= 8.5.0, <= 8.5.100; fixed in 9.0.104, 10.1.40, 11.0.6 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3p2h-wqq4-wf4h (GitHub-reviewed advisory GHSA-3p2h-wqq4-wf4h lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=9.0.76 =10.1.10 =11.0.0-M2 =8.5.0 =9.0.76 =10.1.10 =11.0.0-M2 =8.5.0 <=8.5.100) Commands are suggestions: review each one before running it.
Loading voting…