Skip to content

← Actionable
Medium, CVSS 6.3

Kirby vulnerable to path traversal of collection names during file system lookup

CVE-2025-31493GHSA-x275-h9j4-7p4h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 4.7.1, 3.10.1.2, 3.9.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 3.9.8.3>= 3.10.0, < 3.10.1.2>= 4.0.0, < 4.7.1
    Fixed in
    4.7.1, 3.9.8.3, 3.10.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-31493: 0.59% estimated exploitation activity in the next 30 days; percentile 48.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby sites that use the collection() helper or $kirby-collection() method with a dynamic collection name (such as a collection name that depends on request or user data). Sites that only use fixed calls to the collection() helper/$kirby-collection() method (i.e. calls with a simple string for the collection name) are not affected. ---- Introduction Kirby's collection() helper and $kirby-collection() method (in the following abbreviated to the collection() helper) allow to load PHP logic files that are normally stored in the site/collections folder or registered by plugins through the collections plugin extension. If the collection() helper is called with an arbitrary collection name, Kirby first checks if a file with this name exists in the collections root (which defaults to site/collections). This logic was vulnerable against path traversal attacks. By using special elements such as .. and / separators, attackers can escape outside of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x275-h9j4-7p4h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31493

Advisory: Kirby vulnerable to path traversal of collection names during file system lookup
IDs: CVE-2025-31493, GHSA-x275-h9j4-7p4h
Record: https://patchnext.com/advisories/cve-2025-31493 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 4.7.1, 3.10.1.2, 3.9.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 3.9.8.3; >= 3.10.0, < 3.10.1.2; >= 4.0.0, < 4.7.1; fixed in 4.7.1, 3.9.8.3, 3.10.1.2

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x275-h9j4-7p4h (GitHub-reviewed advisory GHSA-x275-h9j4-7p4h lists affected ranges: Packagist getkirby/cms >=0 =3.10.0 =4.0.0 <4.7.1)

Commands are suggestions: review each one before running it.

Loading voting…