Skip to content

← Actionable
High, CVSS 7.5

GraphQL grant on a property might be cached with different objects

CVE-2025-31485GHSA-428q-q3vv-3fq3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (api-platform/core 4.1.5, 4.0.22, 3.4.17; api-platform/graphql 4.1.5, 4.0.22, 3.4.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist api-platform/core

    Affected
    < 3.4.17>= 4.0.0-alpha.1, < 4.0.22>= 4.1.0-alpha.1, < 4.1.5
    Fixed in
    4.0.22, 4.1.5, 3.4.17
  • Packagist api-platform/graphql

    Affected
    < 3.4.17>= 4.0.0-alpha.1, < 4.0.22>= 4.1.0-alpha.1, < 4.1.5
    Fixed in
    4.0.22, 4.1.5, 3.4.17

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-428q-q3vv-3fq3 lists affected ranges: Packagist api-platform/graphql >=0 =4.0.0-alpha.1 =4.1.0-alpha.1 =0 =4.0.0-alpha.1 =4.1.0-alpha.1 <4.1.5

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-31485: 0.63% estimated exploitation activity in the next 30 days; percentile 50.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Original message: I found an issue with security grants on on properties in the GraphQL ItemNormalizer: If you use something like #[ApiProperty(security: 'isgranted("PROPERTYREAD", [object, property])')] on a member of an entity, the grant gets cached and is only evaluated once, even if the object in question is a different one. There is the ApiPlatform\GraphQl\Serializer\ItemNormalizer::isCacheKeySafe() method that seems to be intended to prevent this: https://github.com/api-platform/core/blob/88f5ac50d20d6510686a7552310cc567fcca45bf/src/GraphQl/Serializer/ItemNormalizer.php#L160-L164 and in its usage on line 90 it does indeed not create a cache key, but the parent::normalize() that is called afterwards still creates the cache key and causes the issue. Impact It grants access to properties that it should not. Workarounds Override the ItemNormalizer. Patched at: https://github.com/api-platform/core/commit/7af65aad13037d7649348ee3dcd88e084ef771f8

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-428q-q3vv-3fq3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31485

Advisory: GraphQL grant on a property might be cached with different objects
IDs: CVE-2025-31485, GHSA-428q-q3vv-3fq3
Record: https://patchnext.com/advisories/cve-2025-31485 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: api-platform/core 4.1.5, 4.0.22, 3.4.17; api-platform/graphql 4.1.5, 4.0.22, 3.4.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist api-platform/core: affected < 3.4.17; >= 4.0.0-alpha.1, < 4.0.22; >= 4.1.0-alpha.1, < 4.1.5; fixed in 4.0.22, 4.1.5, 3.4.17
- Packagist api-platform/graphql: affected < 3.4.17; >= 4.0.0-alpha.1, < 4.0.22; >= 4.1.0-alpha.1, < 4.1.5; fixed in 4.0.22, 4.1.5, 3.4.17

## Suggested inspection (read-only)
- Packagist api-platform/core: check the installed version with your package manager.
- Packagist api-platform/graphql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on api-platform/core, api-platform/graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-428q-q3vv-3fq3 (GitHub-reviewed advisory GHSA-428q-q3vv-3fq3 lists affected ranges: Packagist api-platform/graphql >=0 =4.0.0-alpha.1 =4.1.0-alpha.1 =0 =4.0.0-alpha.1 =4.1.0-alpha.1 <4.1.5)

Commands are suggestions: review each one before running it.

Loading voting…