Skip to content

← Actionable
Critical, CVSS 9.3amended

Improper Scope Validation in the open Endpoint of tauri-plugin-shell

CVE-2025-31477GHSA-c9pr-q8gx-3mgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tauri-apps/plugin-shell 2.2.1; tauri-plugin-shell 2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-31477: 1.04% estimated exploitation activity in the next 30 days; percentile 64.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Tauri shell plugin exposes functionality to execute code and open programs on the system. The open endpoint of this plugin is designed to allow open functionality with the system opener (e.g. xdg-open on Linux). This was meant to be restricted to a reasonable number of protocols like https or mailto by default. This default restriction was not functional due to improper validation of the allowed protocols, allowing for potentially dangerous protocols like file://, smb://, or nfs:// and others to be opened by the system registered protocol handler. By passing untrusted user input to the open endpoint these potentially dangerous protocols can be abused to gain remote code execution on the system. This either requires direct exposure of the endpoint to application users or code execution in the frontend of a Tauri application. You are not affected if you have explicitly configured a validation regex or manually set the open endpoint to true in the plugin configuration.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c9pr-q8gx-3mgp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c9pr-q8gx-3mgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31477

Advisory: Improper Scope Validation in the `open` Endpoint of `tauri-plugin-shell`
IDs: CVE-2025-31477, GHSA-c9pr-q8gx-3mgp
Record: https://patchnext.com/advisories/cve-2025-31477 (revision 3, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @tauri-apps/plugin-shell 2.2.1; tauri-plugin-shell 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @tauri-apps/plugin-shell: affected < 2.2.1; fixed in 2.2.1
- crates.io tauri-plugin-shell: affected < 2.2.1; fixed in 2.2.1

## Suggested inspection (read-only)
- `npm ls @tauri-apps/plugin-shell --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- crates.io tauri-plugin-shell: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @tauri-apps/plugin-shell, tauri-plugin-shell.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c9pr-q8gx-3mgp (OSV record GHSA-c9pr-q8gx-3mgp lists affected ranges: crates.io tauri-plugin-shell >=0 =0 <2.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-c9pr-q8gx-3mgp (GitHub-reviewed advisory GHSA-c9pr-q8gx-3mgp lists affected ranges: crates.io tauri-plugin-shell >=0 =0 <2.2.1)

Commands are suggestions: review each one before running it.

Loading voting…