Skip to content

← Actionable
Low, CVSS 3.0

Mattermost doesn't restrict domains LLM can request to contact upstream

CVE-2025-31363GHSA-9h6j-4ffx-cm84

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.5.1, 10.4.3, 9.11.10, 8.0.0-20250218121836-2b5275d87136), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    >= 10.5.0, < 10.5.1>= 10.4.0, < 10.4.3>= 9.11.0, < 9.11.10< 8.0.0-20250218121836-2b5275d87136
    Fixed in
    10.5.1, 10.4.3, 8.0.0-20250218121836-2b5275d87136, 9.11.10

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-9h6j-4ffx-cm84 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =10.4.0 =9.11.0 =0 <8.0.0-20250218121836-2b5275d87136

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2025-31363: 0.29% estimated exploitation activity in the next 30 days; percentile 21.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9h6j-4ffx-cm84

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31363

Advisory: Mattermost doesn't restrict domains LLM can request to contact upstream
IDs: CVE-2025-31363, GHSA-9h6j-4ffx-cm84
Record: https://patchnext.com/advisories/cve-2025-31363 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.5.1, 10.4.3, 9.11.10, 8.0.0-20250218121836-2b5275d87136. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 10.5.0, < 10.5.1; >= 10.4.0, < 10.4.3; >= 9.11.0, < 9.11.10; < 8.0.0-20250218121836-2b5275d87136; fixed in 10.5.1, 10.4.3, 8.0.0-20250218121836-2b5275d87136, 9.11.10

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9h6j-4ffx-cm84 (GitHub-reviewed advisory GHSA-9h6j-4ffx-cm84 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =10.4.0 =9.11.0 =0 <8.0.0-20250218121836-2b5275d87136)

Commands are suggestions: review each one before running it.

Loading voting…