jooby-pac4j: deserialization of untrusted data
CVE-2025-31129GHSA-7c5v-895v-w4q5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jooby:jooby-pac4j 3.7.0, 2.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jooby:jooby-pac4j
- Affected
- < 2.17.0>= 3.0.0.M1, < 3.7.0
- Fixed in
- 2.17.0, 3.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7c5v-895v-w4q5 lists affected ranges: Maven io.jooby:jooby-pac4j >=0 =3.0.0.M1 <3.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-31129: 0.66% estimated exploitation activity in the next 30 days; percentile 51.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Versions after 2.x and before 3.x of io.jooby:jooby-pac4j can cause deserialization of untrusted data Patches - 2.17.0 (2.x) - 3.7.0 (3.x) Workarounds - Not using io.jooby:jooby-pac4j until it gets patches. - Check what values you put/save on session References Version 2.x: https://github.com/jooby-project/jooby/blob/v2.x/modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java#L39-L45 Version 3.x: https://github.com/jooby-project/jooby/blob/v3.6.1/modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java#L77-L84 Cause In module pac4j io.jooby.internal.pac4j.SessionStoreImpl#get , it is used to handle sessions , and trying to get key value. In strToObject function ,it's trying to deserialize value when value starts with "b64~" , which might cause deserialization of untrusted data. modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java Here's a small demo using SessionStoreImpl#get to handle sessions ,and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7c5v-895v-w4q5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-31129 Advisory: jooby-pac4j: deserialization of untrusted data IDs: CVE-2025-31129, GHSA-7c5v-895v-w4q5 Record: https://patchnext.com/advisories/cve-2025-31129 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jooby:jooby-pac4j 3.7.0, 2.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jooby:jooby-pac4j: affected < 2.17.0; >= 3.0.0.M1, < 3.7.0; fixed in 2.17.0, 3.7.0 ## Suggested inspection (read-only) - Maven io.jooby:jooby-pac4j: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jooby:jooby-pac4j. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7c5v-895v-w4q5 (GitHub-reviewed advisory GHSA-7c5v-895v-w4q5 lists affected ranges: Maven io.jooby:jooby-pac4j >=0 =3.0.0.M1 <3.7.0) Commands are suggestions: review each one before running it.
Loading voting…