generator-jhipster-entity-audit vulnerable to Unsafe Reflection when having Javers selected as Entity Audit Framework
CVE-2025-31119GHSA-7rmp-3g9f-cvq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (generator-jhipster-entity-audit 5.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm generator-jhipster-entity-audit
- Affected
- < 5.9.1
- Fixed in
- 5.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7rmp-3g9f-cvq8 lists affected ranges: npm generator-jhipster-entity-audit >=0 <5.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7rmp-3g9f-cvq8 lists affected ranges: npm generator-jhipster-entity-audit >=0 <5.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-31119: 0.54% estimated exploitation activity in the next 30 days; percentile 45.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary CWE-470 (Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') when having Javers selected as Entity Audit Framework Details In the following two occurences, user input directly leads to class loading without checking against e.g. a whitelist of allowed classes. This is also known as CWE-470 https://github.com/jhipster/generator-jhipster-entity-audit/blob/e21e83135d10c77d92203c89cb0b0063914e8fe0/generators/spring-boot-javers/templates/src/main/java/package/web/rest/JaversEntityAuditResource.java.ejs#L88 https://github.com/jhipster/generator-jhipster-entity-audit/blob/e21e83135d10c77d92203c89cb0b0063914e8fe0/generators/spring-boot-javers/templates/src/main/java/package/web/rest/JaversEntityAuditResource.java.ejs#L124 So, if an attacker manages to place some malicious classes into the classpath and also has access to these REST interface for calling the mentioned REST endpoints, using these lines of code can lead to unintended remote code execution.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7rmp-3g9f-cvq8
- Revision 1 · created ·
Published from osv record GHSA-7rmp-3g9f-cvq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-31119 Advisory: generator-jhipster-entity-audit vulnerable to Unsafe Reflection when having Javers selected as Entity Audit Framework IDs: CVE-2025-31119, GHSA-7rmp-3g9f-cvq8 Record: https://patchnext.com/advisories/cve-2025-31119 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: generator-jhipster-entity-audit 5.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm generator-jhipster-entity-audit: affected < 5.9.1; fixed in 5.9.1 ## Suggested inspection (read-only) - `npm ls generator-jhipster-entity-audit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on generator-jhipster-entity-audit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7rmp-3g9f-cvq8 (OSV record GHSA-7rmp-3g9f-cvq8 lists affected ranges: npm generator-jhipster-entity-audit >=0 <5.9.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7rmp-3g9f-cvq8 (GitHub-reviewed advisory GHSA-7rmp-3g9f-cvq8 lists affected ranges: npm generator-jhipster-entity-audit >=0 <5.9.1) Commands are suggestions: review each one before running it.
Loading voting…