Skip to content

← Actionable
Medium, CVSS 5.0amended

LlamaIndex has Incomplete Documentation of Program Execution related to JsonPickleSerializer component

CVE-2025-3108GHSA-m84c-4c34-28gf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.12.41; llama-index-core 0.12.41), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2025-3108: 0.50% estimated exploitation activity in the next 30 days; percentile 42.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Incomplete Documentation of Program Execution exists in the run-llama/llamaindex library's JsonPickleSerializer component, affecting versions v0.12.27 through v0.12.40. This vulnerability allows remote code execution due to an insecure fallback to Python's pickle module. JsonPickleSerializer prioritizes deserialization using pickle.loads(), which can execute arbitrary code when processing untrusted data. Attackers can exploit this by crafting malicious payloads to achieve full system compromise. The root cause involves the use of an insecure fallback strategy without sufficient input validation or protective safeguards. Version 0.12.41 renames JsonPickleSerializer to PickleSerializer and adds a warning to the docs to only use PickleSerializer to deserialize safe things.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m84c-4c34-28gf

  2. Revision 2 · amended ·

    Amended from osv record PYSEC-2025-249

  3. Revision 1 · created ·

    Published from osv record GHSA-m84c-4c34-28gf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3108

Advisory: LlamaIndex has Incomplete Documentation of Program Execution related to JsonPickleSerializer component
IDs: CVE-2025-3108, GHSA-m84c-4c34-28gf
Record: https://patchnext.com/advisories/cve-2025-3108 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llama-index 0.12.41; llama-index-core 0.12.41. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llama-index: affected >= 0.12.27, < 0.12.41; fixed in 0.12.41
- PyPI llama-index-core: affected >= 0.11.15, <= 0.12.40; fixed in 0.12.41

## Suggested inspection (read-only)
- `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show llama-index-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index, llama-index-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m84c-4c34-28gf (OSV record GHSA-m84c-4c34-28gf lists affected ranges: PyPI llama-index-core >=0.11.15 <0.12.41 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-249 (OSV record PYSEC-2025-249 lists affected ranges: PyPI llama-index >=0.12.27 <0.12.41 (fixed))
- Verified: https://github.com/advisories/GHSA-m84c-4c34-28gf (GitHub-reviewed advisory GHSA-m84c-4c34-28gf lists affected ranges: PyPI llama-index-core >=0.11.15 <=0.12.40)

Commands are suggestions: review each one before running it.

Loading voting…