Apache Airflow Common SQL Provider Vulnerable to SQL Injection
CVE-2025-30473GHSA-5r62-mjf5-xwhj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-common-sql 1.24.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-common-sql
- Affected
- < 1.24.1
- Fixed in
- 1.24.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5r62-mjf5-xwhj lists affected ranges: PyPI apache-airflow-providers-common-sql >=0 <1.24.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5r62-mjf5-xwhj lists affected ranges: PyPI apache-airflow-providers-common-sql >=0 <1.24.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-30473: 0.95% estimated exploitation activity in the next 30 days; percentile 61.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow Common SQL Provider. When using the partition clause in SQLTableCheckOperator as parameter (which was a recommended pattern), Authenticated UI User could inject arbitrary SQL command when triggering DAG exposing partitionclause to the user. This allowed the DAG Triggering user to escalate privileges to execute those arbitrary commands which they normally would not have. This issue affects Apache Airflow Common SQL Provider: before 1.24.1. Users are recommended to upgrade to version 1.24.1, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5r62-mjf5-xwhj
- Revision 1 · created ·
Published from osv record GHSA-5r62-mjf5-xwhj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30473 Advisory: Apache Airflow Common SQL Provider Vulnerable to SQL Injection IDs: CVE-2025-30473, GHSA-5r62-mjf5-xwhj Record: https://patchnext.com/advisories/cve-2025-30473 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-common-sql 1.24.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-common-sql: affected < 1.24.1; fixed in 1.24.1 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-common-sql`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-common-sql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5r62-mjf5-xwhj (OSV record GHSA-5r62-mjf5-xwhj lists affected ranges: PyPI apache-airflow-providers-common-sql >=0 <1.24.1 (fixed)) - Verified: https://github.com/advisories/GHSA-5r62-mjf5-xwhj (GitHub-reviewed advisory GHSA-5r62-mjf5-xwhj lists affected ranges: PyPI apache-airflow-providers-common-sql >=0 <1.24.1) Commands are suggestions: review each one before running it.
Loading voting…