Skip to content

← Actionable
Medium, CVSS 6.9amended

AWS SAM CLI Path Traversal allows file copy to build container

CVE-2025-3047GHSA-px37-jpqx-97q9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aws-sam-cli 1.133.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-3047: 0.78% estimated exploitation activity in the next 30 days; percentile 56.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AWS Serverless Application Model Command Line Interface (AWS SAM CLI) is an open-source CLI tool that helps Lambda developers to build and develop Lambda applications locally on their computers using Docker. When running the AWS SAM CLI build process with Docker and symlinks are included in the build files, the container environment allows a user to access privileged files on the host by leveraging the elevated permissions granted to the tool. A user could leverage the elevated permissions to access restricted files via symlinks and copy them to a more permissive location on the container. Users should upgrade to v1.133.0 or newer and ensure any forked or derivative code is patched to incorporate the new fixes. Impact This issue is limited to the local workspace and does not affect AWS services, production environments or cross-account resources. The issue only affects local workspaces using AWS SAM CLI with container builds (--use-container), potentially allowing access…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-px37-jpqx-97q9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-px37-jpqx-97q9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3047

Advisory: AWS SAM CLI Path Traversal allows file copy to build container
IDs: CVE-2025-3047, GHSA-px37-jpqx-97q9
Record: https://patchnext.com/advisories/cve-2025-3047 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aws-sam-cli 1.133.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aws-sam-cli: affected < 1.133.0; fixed in 1.133.0

## Suggested inspection (read-only)
- `python -m pip show aws-sam-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aws-sam-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-px37-jpqx-97q9 (OSV record GHSA-px37-jpqx-97q9 lists affected ranges: PyPI aws-sam-cli >=0 <1.133.0 (fixed))
- Verified: https://github.com/advisories/GHSA-px37-jpqx-97q9 (GitHub-reviewed advisory GHSA-px37-jpqx-97q9 lists affected ranges: PyPI aws-sam-cli >=0 <1.133.0)

Commands are suggestions: review each one before running it.

Loading voting…