Skip to content

← Actionable
High, CVSS 7.5amended

LlamaIndex is vulnerable to Path Traversal attack through its ObsidianReader class

CVE-2025-3046GHSA-fmrf-6jv9-qjc7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.12.28; llama-index-readers-obsidian 0.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-3046: 0.64% estimated exploitation activity in the next 30 days; percentile 50.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in the ObsidianReader class in LlamaIndex Readers Integration: Obsidian before version 0.5.1 from the run-llama/llamaindex repository (versions 0.12.23 to 0.12.28) allows for arbitrary file read through symbolic links. The ObsidianReader fails to resolve symlinks to their real paths and does not validate whether the resolved paths lie within the intended directory. This flaw enables attackers to place symlinks pointing to files outside the vault directory, which are then processed as valid Markdown files, potentially exposing sensitive information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fmrf-6jv9-qjc7

  2. Revision 2 · amended ·

    Amended from osv record PYSEC-2025-248

  3. Revision 1 · created ·

    Published from osv record GHSA-fmrf-6jv9-qjc7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3046

Advisory: LlamaIndex is vulnerable to Path Traversal attack through its ObsidianReader class
IDs: CVE-2025-3046, GHSA-fmrf-6jv9-qjc7
Record: https://patchnext.com/advisories/cve-2025-3046 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llama-index 0.12.28; llama-index-readers-obsidian 0.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llama-index: affected >= 0.12.23, < 0.12.28; fixed in 0.12.28
- PyPI llama-index-readers-obsidian: affected < 0.5.1; fixed in 0.5.1

## Suggested inspection (read-only)
- `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show llama-index-readers-obsidian`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index, llama-index-readers-obsidian.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fmrf-6jv9-qjc7 (OSV record GHSA-fmrf-6jv9-qjc7 lists affected ranges: PyPI llama-index-readers-obsidian >=0 <0.5.1 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-248 (OSV record PYSEC-2025-248 lists affected ranges: PyPI llama-index >=0.12.23 <0.12.28 (fixed))
- Verified: https://github.com/advisories/GHSA-fmrf-6jv9-qjc7 (GitHub-reviewed advisory GHSA-fmrf-6jv9-qjc7 lists affected ranges: PyPI llama-index-readers-obsidian >=0 <0.5.1)

Commands are suggestions: review each one before running it.

Loading voting…