jupyterlab-git has a command injection vulnerability in "Open Git Repository in Terminal"
CVE-2025-30370GHSA-cj5w-8mjf-r5f8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab-git 0.51.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterlab-git
- Affected
- < 0.51.1
- Fixed in
- 0.51.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cj5w-8mjf-r5f8 lists affected ranges: PyPI jupyterlab-git >=0 <0.51.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cj5w-8mjf-r5f8 lists affected ranges: PyPI jupyterlab-git >=0 <0.51.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:H
- EPSS
- CVE-2025-30370: 0.60% estimated exploitation activity in the next 30 days; percentile 48.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview On many platforms, a third party can create a Git repository under a name that includes a shell command substitution [^1] string in the syntax $(<command). These directory names are allowed in macOS and a majority of Linux distributions [^2]. If a user starts jupyter-lab in a parent directory of this inappropriately-named Git repository, opens it, and clicks "Git Open Git Repository in Terminal" from the menu bar, then the injected command <command is run in the user's shell without the user's permission. This issue is occurring because when that menu entry is clicked, jupyterlab-git opens the terminal and runs cd <git-repo-path through the shell to set the current directory [^3]. Doing so runs any command substitution strings present in the directory name, which leads to the command injection issue described here. A previous patch provided an incomplete fix [^4]. [^1]: https://www.gnu.org/software/bash/manual/htmlnode/Command-Substitution.html [^2]:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cj5w-8mjf-r5f8
- Revision 1 · created ·
Published from osv record GHSA-cj5w-8mjf-r5f8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30370 Advisory: jupyterlab-git has a command injection vulnerability in "Open Git Repository in Terminal" IDs: CVE-2025-30370, GHSA-cj5w-8mjf-r5f8 Record: https://patchnext.com/advisories/cve-2025-30370 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterlab-git 0.51.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterlab-git: affected < 0.51.1; fixed in 0.51.1 ## Suggested inspection (read-only) - `python -m pip show jupyterlab-git`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterlab-git. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cj5w-8mjf-r5f8 (OSV record GHSA-cj5w-8mjf-r5f8 lists affected ranges: PyPI jupyterlab-git >=0 <0.51.1 (fixed)) - Verified: https://github.com/advisories/GHSA-cj5w-8mjf-r5f8 (GitHub-reviewed advisory GHSA-cj5w-8mjf-r5f8 lists affected ranges: PyPI jupyterlab-git >=0 <0.51.1) Commands are suggestions: review each one before running it.
Loading voting…