webpack-dev-server users' source code may be stolen when they access a malicious web site with non-Chromium based browser
CVE-2025-30360GHSA-9jgg-88mc-972h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpack-dev-server 5.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 5.2.0
- Fixed in
- 5.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9jgg-88mc-972h lists affected ranges: npm webpack-dev-server >=0 <5.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jgg-88mc-972h lists affected ranges: npm webpack-dev-server >=0 <=5.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-30360: 0.36% estimated exploitation activity in the next 30 days; percentile 29.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Source code may be stolen when you access a malicious web site with non-Chromium based browser. Details The Origin header is checked to prevent Cross-site WebSocket hijacking from happening which was reported by CVE-2018-14732. But webpack-dev-server always allows IP address Origin headers. https://github.com/webpack/webpack-dev-server/blob/55220a800ba4e30dbde2d98785ecf4c80b32f711/lib/Server.js#L3113-L3127 This allows websites that are served on IP addresses to connect WebSocket. By using the same method described in the article linked from CVE-2018-14732, the attacker get the source code. related commit: https://github.com/webpack/webpack-dev-server/commit/72efaab83381a0e1c4914adf401cbd210b7de7eb (note that checkHost function was only used for Host header to prevent DNS rebinding attacks so this change itself is fine. This vulnerability does not affect Chrome 94+ (and other Chromium based browsers) users due to the non-HTTPS private access blocking feature. PoC 1. Download…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9jgg-88mc-972h
- Revision 1 · created ·
Published from osv record GHSA-9jgg-88mc-972h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30360 Advisory: webpack-dev-server users' source code may be stolen when they access a malicious web site with non-Chromium based browser IDs: CVE-2025-30360, GHSA-9jgg-88mc-972h Record: https://patchnext.com/advisories/cve-2025-30360 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: webpack-dev-server 5.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm webpack-dev-server: affected <= 5.2.0; fixed in 5.2.1 ## Suggested inspection (read-only) - `npm ls webpack-dev-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on webpack-dev-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9jgg-88mc-972h (OSV record GHSA-9jgg-88mc-972h lists affected ranges: npm webpack-dev-server >=0 <5.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9jgg-88mc-972h (GitHub-reviewed advisory GHSA-9jgg-88mc-972h lists affected ranges: npm webpack-dev-server >=0 <=5.2.0) Commands are suggestions: review each one before running it.
Loading voting…