Skip to content

← Actionable
Medium, CVSS 5.3amended

webpack-dev-server users' source code may be stolen when they access a malicious web site

CVE-2025-30359GHSA-4v9v-hfq4-rm2v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpack-dev-server 5.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-30359: 0.60% estimated exploitation activity in the next 30 days; percentile 48.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Source code may be stolen when you access a malicious web site. Details Because the request for classic script by a script tag is not subject to same origin policy, an attacker can inject <script src="http://localhost:8080/main.js" in their site and run the script. Note that the attacker has to know the port and the output entrypoint script path. Combined with prototype pollution, the attacker can get a reference to the webpack runtime variables. By using Function::toString against the values in webpackmodules, the attacker can get the source code. PoC 1. Download reproduction.zip and extract it 2. Run npm i 3. Run npx webpack-dev-server 4. Open https://e29c9a88-a242-4fb4-9e64-b24c9d29b35b.pages.dev/ 5. You can see the source code output in the document and the devtools console. The script in the POC site is: This script uses the function generated by renderRequire. Especially, it uses the fact that Array::forEach is called for webpackrequire.i and execOptions contains…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4v9v-hfq4-rm2v

  2. Revision 1 · created ·

    Published from osv record GHSA-4v9v-hfq4-rm2v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30359

Advisory: webpack-dev-server users' source code may be stolen when they access a malicious web site
IDs: CVE-2025-30359, GHSA-4v9v-hfq4-rm2v
Record: https://patchnext.com/advisories/cve-2025-30359 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webpack-dev-server 5.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm webpack-dev-server: affected <= 5.2.0; fixed in 5.2.1

## Suggested inspection (read-only)
- `npm ls webpack-dev-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webpack-dev-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4v9v-hfq4-rm2v (OSV record GHSA-4v9v-hfq4-rm2v lists affected ranges: npm webpack-dev-server >=0 <5.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4v9v-hfq4-rm2v (GitHub-reviewed advisory GHSA-4v9v-hfq4-rm2v lists affected ranges: npm webpack-dev-server >=0 <=5.2.0)

Commands are suggestions: review each one before running it.

Loading voting…