Synapse vulnerable to federation denial of service via malformed events
CVE-2025-30355GHSA-v56r-hwv5-mxg6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.127.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- < 1.127.1
- Fixed in
- 1.127.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v56r-hwv5-mxg6 lists affected ranges: PyPI matrix-synapse >=0 <1.127.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v56r-hwv5-mxg6 lists affected ranges: PyPI matrix-synapse >=0 <1.127.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
- EPSS
- CVE-2025-30355: 1.23% estimated exploitation activity in the next 30 days; percentile 68.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A malicious server can craft events with a depth outside the integer range allowed by Canonical JSON. When such an event is received by Synapse version up to 1.127.0, it prevents it from federating with other servers. The vulnerability has been exploited in the wild. Patches Fixed in Synapse v1.127.1. Workarounds Closed federation environments of trusted servers or non-federating installations are not affected. For more information If you have any questions or comments about this advisory, please email us at security at element.io.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v56r-hwv5-mxg6
- Revision 1 · created ·
Published from osv record GHSA-v56r-hwv5-mxg6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30355 Advisory: Synapse vulnerable to federation denial of service via malformed events IDs: CVE-2025-30355, GHSA-v56r-hwv5-mxg6 Record: https://patchnext.com/advisories/cve-2025-30355 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.127.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected < 1.127.1; fixed in 1.127.1 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v56r-hwv5-mxg6 (OSV record GHSA-v56r-hwv5-mxg6 lists affected ranges: PyPI matrix-synapse >=0 <1.127.1 (fixed)) - Verified: https://github.com/advisories/GHSA-v56r-hwv5-mxg6 (GitHub-reviewed advisory GHSA-v56r-hwv5-mxg6 lists affected ranges: PyPI matrix-synapse >=0 <1.127.1) Commands are suggestions: review each one before running it.
Loading voting…