Directus's webhook trigger flows can leak sensitive data
CVE-2025-30353GHSA-fm3h-p9wm-h74h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- >= 9.12.0, < 11.5.0
- Fixed in
- 11.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fm3h-p9wm-h74h lists affected ranges: npm directus >=9.12.0 <11.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fm3h-p9wm-h74h lists affected ranges: npm directus >=9.12.0 <11.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2025-30353: 0.53% estimated exploitation activity in the next 30 days; percentile 44.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Describe the Bug In Directus, when a Flow with the "Webhook" trigger and the "Data of Last Operation" response body encounters a ValidationError thrown by a failed condition operation, the API response includes sensitive data. This includes environmental variables, sensitive API keys, user accountability information, and operational data. This issue poses a significant security risk, as any unintended exposure of this data could lead to potential misuse. To Reproduce Steps to Reproduce: 1. Create a Flow in Directus with: - Trigger: Webhook - Response Body: Data of Last Operation 2. Add a condition that is likely to fail. 3. Trigger the Flow with any input data that will fail the condition. 4. Observe the API response, which includes sensitive information like: - Environmental variables ($env) - Authorization headers - User details under $accountability - Previous operational data. Expected Behavior: In the event of a ValidationError, the API response should only contain relevant…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fm3h-p9wm-h74h
- Revision 1 · created ·
Published from osv record GHSA-fm3h-p9wm-h74h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30353 Advisory: Directus's webhook trigger flows can leak sensitive data IDs: CVE-2025-30353, GHSA-fm3h-p9wm-h74h Record: https://patchnext.com/advisories/cve-2025-30353 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected >= 9.12.0, < 11.5.0; fixed in 11.5.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fm3h-p9wm-h74h (OSV record GHSA-fm3h-p9wm-h74h lists affected ranges: npm directus >=9.12.0 <11.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-fm3h-p9wm-h74h (GitHub-reviewed advisory GHSA-fm3h-p9wm-h74h lists affected ranges: npm directus >=9.12.0 <11.5.0) Commands are suggestions: review each one before running it.
Loading voting…