Suspended Directus user can continue to use session token to access API
CVE-2025-30351GHSA-56p6-qw3c-fq2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@directus/types 13.0.0; directus 11.5.0; @directus/api 24.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @directus/types
- Affected
- >= 11.0.7, < 13.0.0
- Fixed in
- 13.0.0
npm directus
- Affected
- >= 10.10.0, < 11.5.0
- Fixed in
- 11.5.0
npm @directus/api
- Affected
- >= 18.0.0, < 24.0.1
- Fixed in
- 24.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-56p6-qw3c-fq2g lists affected ranges: npm directus >=10.10.0 =18.0.0 =11.0.7 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-56p6-qw3c-fq2g lists affected ranges: npm directus >=10.10.0 =18.0.0 =11.0.7 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-30351: 0.37% estimated exploitation activity in the next 30 days; percentile 31.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Since the user status is not checked when verifying a session token a suspended user can use the token generated in session auth mode to access the API despite their status. Details There is a check missing in verifySessionJWT to verify that a user is actually still active and allowed to access the API. Right now one can extract the session token obtained by, e.g. login in to the app while still active and then, after the user has been suspended continue to use that token until it expires. PoC Create an active user Log in with that user and note the session cookie Suspend the user (and don't trigger an /auth/refresh call, as that invalidates the session Access the API with Authorization: Bearer <token Impact This weakens the security of suspending users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-56p6-qw3c-fq2g
- Revision 1 · created ·
Published from osv record GHSA-56p6-qw3c-fq2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30351 Advisory: Suspended Directus user can continue to use session token to access API IDs: CVE-2025-30351, GHSA-56p6-qw3c-fq2g Record: https://patchnext.com/advisories/cve-2025-30351 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @directus/types 13.0.0; directus 11.5.0; @directus/api 24.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @directus/types: affected >= 11.0.7, < 13.0.0; fixed in 13.0.0 - npm directus: affected >= 10.10.0, < 11.5.0; fixed in 11.5.0 - npm @directus/api: affected >= 18.0.0, < 24.0.1; fixed in 24.0.1 ## Suggested inspection (read-only) - `npm ls @directus/types --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @directus/types, directus, @directus/api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-56p6-qw3c-fq2g (OSV record GHSA-56p6-qw3c-fq2g lists affected ranges: npm directus >=10.10.0 =18.0.0 =11.0.7 <13.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-56p6-qw3c-fq2g (GitHub-reviewed advisory GHSA-56p6-qw3c-fq2g lists affected ranges: npm directus >=10.10.0 =18.0.0 =11.0.7 <13.0.0) Commands are suggestions: review each one before running it.
Loading voting…