Skip to content

← Actionable
Low, CVSS 2.1amended

Shescape has potential environment variable exposure on Windows with CMD

CVE-2025-30222GHSA-66pp-5p9w-q87j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shescape 2.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm shescape

    Affected
    >= 1.7.2, < 2.1.2
    Fixed in
    2.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-30222: 0.19% estimated exploitation activity in the next 30 days; percentile 9.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This impact users of Shescape on Windows that explicitly configure shell: 'cmd.exe' or shell: true using any of quote/quoteAll/escape/escapeAll. An attacker may be able to get read-only access to environment variables. Example: For Shescape prior to v2.0.0, the options object must have shell: 'cmd.exe' or shell: undefined and interpolation: true. Patches This bug has been patched in v2.1.2 which you can upgrade to now. If you are already using v2 of Shescape, no further changes are required. If you are using v1 of Shescape, follow the migration guide to upgrade to v2. There is no plan to release a patch compatible with v1 of Shescape. Workarounds Alternatively, users can remove all instances of % from user input before using Shescape. References - Shescape Pull Request #1916 - Shescape commit 0a81f1e - Shescape release v2.1.2 For more information - Comment on Pull Request #1916 - Comment on commit 0a81f1e - Open an issue at https://github.com/ericcornelissen/shescape/issues…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-66pp-5p9w-q87j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-66pp-5p9w-q87j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30222

Advisory: Shescape has potential environment variable exposure on Windows with CMD
IDs: CVE-2025-30222, GHSA-66pp-5p9w-q87j
Record: https://patchnext.com/advisories/cve-2025-30222 (revision 3, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shescape 2.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm shescape: affected >= 1.7.2, < 2.1.2; fixed in 2.1.2

## Suggested inspection (read-only)
- `npm ls shescape --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shescape.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-66pp-5p9w-q87j (OSV record GHSA-66pp-5p9w-q87j lists affected ranges: npm shescape >=1.7.2 <2.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-66pp-5p9w-q87j (GitHub-reviewed advisory GHSA-66pp-5p9w-q87j lists affected ranges: npm shescape >=1.7.2 <2.1.2)

Commands are suggestions: review each one before running it.

Loading voting…