[XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service
CVE-2025-30220GHSA-jj54-8f66-c5pc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-wfs 2.27.1, 2.26.3, 2.25.7; org.geoserver.web:gs-web-app 2.27.1, 2.26.3, 2.25.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver:gs-wfs
- Affected
- >= 2.27.0, <= 2.27.0>= 2.26.0, <= 2.26.2<= 2.25.6
- Fixed in
- 2.25.7, 2.27.1, 2.26.3
Maven org.geoserver.web:gs-web-app
- Affected
- >= 2.27.0, <= 2.27.0>= 2.26.0, <= 2.26.2<= 2.25.6
- Fixed in
- 2.25.7, 2.27.1, 2.26.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jj54-8f66-c5pc lists affected ranges: Maven org.geoserver.web:gs-web-app >=2.27.0 =2.26.0 =0 =2.27.0 =2.26.0 =0 <=2.25.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
- EPSS
- CVE-2025-30220: 42.29% estimated exploitation activity in the next 30 days; percentile 98.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary GeoServer Web Feature Service (WFS) web service was found to be vulnerable to GeoTools CVE-2025-30220 XML External Entity (XXE) processing attack. It is possible to trigger the parsing of external DTDs and entities, bypassing standard entity resolvers. This allows for Out-of-Band (OOB) data exfiltration of local files accessible by the GeoServer process, and Service Side Request Forgery (SSRF). Details While direct entity resolution is managed by application property ENTITYRESOLUTIONALLOWLIST for XML Parsing, this restriction was not being used by the GeoTools library when building an in-memory XSD Library Schema representation. This bypasses GeoServer's AllowListEntityResolver enabling XXE attacks. PoC No public PoC is provided but this vulnerability has been confirmed to be exploitable through WFS service. Impact Information Disclosure: This vulnerability allows unauthenticated attackers to read arbitrary files from the server's filesystem that are accessible to the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jj54-8f66-c5pc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30220 Advisory: [XBOW-025-068] XML External Entity (XXE) Processing Vulnerability in GeoServer WFS Service IDs: CVE-2025-30220, GHSA-jj54-8f66-c5pc Record: https://patchnext.com/advisories/cve-2025-30220 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-wfs 2.27.1, 2.26.3, 2.25.7; org.geoserver.web:gs-web-app 2.27.1, 2.26.3, 2.25.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver:gs-wfs: affected >= 2.27.0, <= 2.27.0; >= 2.26.0, <= 2.26.2; <= 2.25.6; fixed in 2.25.7, 2.27.1, 2.26.3 - Maven org.geoserver.web:gs-web-app: affected >= 2.27.0, <= 2.27.0; >= 2.26.0, <= 2.26.2; <= 2.25.6; fixed in 2.25.7, 2.27.1, 2.26.3 ## Suggested inspection (read-only) - Maven org.geoserver:gs-wfs: check the installed version with your package manager. - Maven org.geoserver.web:gs-web-app: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver:gs-wfs, org.geoserver.web:gs-web-app. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jj54-8f66-c5pc (GitHub-reviewed advisory GHSA-jj54-8f66-c5pc lists affected ranges: Maven org.geoserver.web:gs-web-app >=2.27.0 =2.26.0 =0 =2.27.0 =2.26.0 =0 <=2.25.6) Commands are suggestions: review each one before running it.
Loading voting…