Skip to content

← Actionable
Low, CVSS 2.3

Kirby vulnerable to path traversal in the router for PHP's built-in server

CVE-2025-30207GHSA-9p3p-w5jf-8xxg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 4.7.1, 3.10.1.2, 3.9.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 3.9.8.3>= 3.10.0, < 3.10.1.2>= 4.0.0, < 4.7.1
    Fixed in
    4.7.1, 3.9.8.3, 3.10.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2025-30207: 0.59% estimated exploitation activity in the next 30 days; percentile 48.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. ---- Introduction For use with PHP's built-in web server, Kirby provides a router.php file. The router delegates requests to static files to PHP so that assets and other static files in the document root can be accessed by the browser. This logic was vulnerable against path traversal attacks. By using special elements such as .. and / separators, attackers can escape outside of the restricted location to access files or directories that are elsewhere on the system. One of the most common special elements is the ../ sequence, which in most modern operating systems is interpreted as the parent directory of the current location. Impact The missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9p3p-w5jf-8xxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30207

Advisory: Kirby vulnerable to path traversal in the router for PHP's built-in server
IDs: CVE-2025-30207, GHSA-9p3p-w5jf-8xxg
Record: https://patchnext.com/advisories/cve-2025-30207 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 4.7.1, 3.10.1.2, 3.9.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 3.9.8.3; >= 3.10.0, < 3.10.1.2; >= 4.0.0, < 4.7.1; fixed in 4.7.1, 3.9.8.3, 3.10.1.2

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9p3p-w5jf-8xxg (GitHub-reviewed advisory GHSA-9p3p-w5jf-8xxg lists affected ranges: Packagist getkirby/cms >=0 =3.10.0 =4.0.0 <4.7.1)

Commands are suggestions: review each one before running it.

Loading voting…